summaryrefslogtreecommitdiffstats
path: root/src/lib-test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib-test/Makefile.am')
-rw-r--r--src/lib-test/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/lib-test/Makefile.am b/src/lib-test/Makefile.am
new file mode 100644
index 0000000..ce7417d
--- /dev/null
+++ b/src/lib-test/Makefile.am
@@ -0,0 +1,20 @@
+noinst_LTLIBRARIES = libtest.la
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-charset
+
+libtest_la_SOURCES = \
+ fuzzer.c \
+ test-common.c \
+ test-istream.c \
+ test-ostream.c \
+ test-subprocess.c
+
+headers = \
+ fuzzer.h \
+ test-common.h \
+ test-subprocess.h
+
+pkginc_libdir=$(pkgincludedir)
+pkginc_lib_HEADERS = $(headers)