summaryrefslogtreecommitdiffstats
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 11:36:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 11:36:04 +0000
commit040eee1aa49b49df4698d83a05af57c220127fd1 (patch)
treef635435954e6ccde5eee9893889e24f30ca68346 /src/lib/Makefile.am
parentInitial commit. (diff)
downloadisc-kea-upstream.tar.xz
isc-kea-upstream.zip
Adding upstream version 2.2.0.upstream/2.2.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
new file mode 100644
index 0000000..f776adc
--- /dev/null
+++ b/src/lib/Makefile.am
@@ -0,0 +1,18 @@
+# The following build order must be maintained.
+SUBDIRS = exceptions util log cryptolink dns asiolink cc testutils database
+
+if HAVE_MYSQL
+SUBDIRS += mysql
+endif
+
+if HAVE_PGSQL
+SUBDIRS += pgsql
+endif
+
+SUBDIRS += config_backend hooks dhcp http config stats
+
+if HAVE_SYSREPO
+SUBDIRS += yang
+endif
+
+SUBDIRS += asiodns dhcp_ddns eval cfgrpt process dhcpsrv d2srv