summaryrefslogtreecommitdiffstats
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
new file mode 100644
index 0000000..f776adc
--- /dev/null
+++ b/src/lib/Makefile.am
@@ -0,0 +1,18 @@
+# The following build order must be maintained.
+SUBDIRS = exceptions util log cryptolink dns asiolink cc testutils database
+
+if HAVE_MYSQL
+SUBDIRS += mysql
+endif
+
+if HAVE_PGSQL
+SUBDIRS += pgsql
+endif
+
+SUBDIRS += config_backend hooks dhcp http config stats
+
+if HAVE_SYSREPO
+SUBDIRS += yang
+endif
+
+SUBDIRS += asiodns dhcp_ddns eval cfgrpt process dhcpsrv d2srv