summaryrefslogtreecommitdiffstats
path: root/test cases/common/255 module warnings/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/255 module warnings/meson.build')
-rw-r--r--test cases/common/255 module warnings/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test cases/common/255 module warnings/meson.build b/test cases/common/255 module warnings/meson.build
new file mode 100644
index 0000000..56e2055
--- /dev/null
+++ b/test cases/common/255 module warnings/meson.build
@@ -0,0 +1,9 @@
+project('module warnings', meson_version : '>= 0.56')
+
+import('python3') # deprecated module
+import('java') # new module
+import('unstable-keyval') # module that has been stabilized, import with unstable-
+import('unstable_simd') # A module with the deprecated `unstable_foo` instead of `unstable-foo`
+
+ice = import('icestorm', required : false)
+assert(not ice.found(), 'unstable-icestorm module should not be importable as `simd`')