summaryrefslogtreecommitdiffstats
path: root/test cases/common/255 module warnings
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/255 module warnings')
-rw-r--r--test cases/common/255 module warnings/meson.build9
-rw-r--r--test cases/common/255 module warnings/test.json16
2 files changed, 25 insertions, 0 deletions
diff --git a/test cases/common/255 module warnings/meson.build b/test cases/common/255 module warnings/meson.build
new file mode 100644
index 0000000..56e2055
--- /dev/null
+++ b/test cases/common/255 module warnings/meson.build
@@ -0,0 +1,9 @@
+project('module warnings', meson_version : '>= 0.56')
+
+import('python3') # deprecated module
+import('java') # new module
+import('unstable-keyval') # module that has been stabilized, import with unstable-
+import('unstable_simd') # A module with the deprecated `unstable_foo` instead of `unstable-foo`
+
+ice = import('icestorm', required : false)
+assert(not ice.found(), 'unstable-icestorm module should not be importable as `simd`')
diff --git a/test cases/common/255 module warnings/test.json b/test cases/common/255 module warnings/test.json
new file mode 100644
index 0000000..5556b90
--- /dev/null
+++ b/test cases/common/255 module warnings/test.json
@@ -0,0 +1,16 @@
+{
+ "stdout": [
+ {
+ "line": "test cases/common/255 module warnings/meson.build:3: WARNING: Project targets '>= 0.56' but uses feature deprecated since '0.48.0': module python3."
+ },
+ {
+ "line": "test cases/common/255 module warnings/meson.build:4: WARNING: Project targets '>= 0.56' but uses feature introduced in '0.60.0': module java."
+ },
+ {
+ "line": "test cases/common/255 module warnings/meson.build:5: WARNING: Project targets '>= 0.56' but uses feature deprecated since '0.56.0': module keyval has been stabilized. drop \"unstable-\" prefix from the module name"
+ },
+ {
+ "line": "test cases/common/255 module warnings/meson.build:6: DEPRECATION: Importing unstable modules as \"unstable_simd\" instead of \"unstable-simd\""
+ }
+ ]
+}