summaryrefslogtreecommitdiffstats
path: root/src/test/thread/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
commit6eb9c5a5657d1fe77b55cc261450f3538d35a94d (patch)
tree657d8194422a5daccecfd42d654b8a245ef7b4c8 /src/test/thread/Makefile
parentInitial commit. (diff)
downloadpostgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.tar.xz
postgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.zip
Adding upstream version 13.4.upstream/13.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/thread/Makefile')
-rw-r--r--src/test/thread/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/test/thread/Makefile b/src/test/thread/Makefile
new file mode 100644
index 0000000..a13c0c6
--- /dev/null
+++ b/src/test/thread/Makefile
@@ -0,0 +1,24 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for tools/thread
+#
+# Copyright (c) 2003-2020, PostgreSQL Global Development Group
+#
+# src/test/thread/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/tools/thread
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+override CFLAGS += $(PTHREAD_CFLAGS)
+
+all: thread_test
+
+thread_test: thread_test.o
+# no need for $LIBS, might not be compiled yet
+ $(CC) $(CFLAGS) $^ $(LDFLAGS) $(LDFLAGS_EX) $(PTHREAD_LIBS) -o $@$(X)
+
+clean distclean maintainer-clean:
+ rm -f thread_test$(X) thread_test.o