summaryrefslogtreecommitdiffstats
path: root/src/test/thread/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/thread/Makefile')
-rw-r--r--src/test/thread/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/test/thread/Makefile b/src/test/thread/Makefile
new file mode 100644
index 0000000..a13c0c6
--- /dev/null
+++ b/src/test/thread/Makefile
@@ -0,0 +1,24 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for tools/thread
+#
+# Copyright (c) 2003-2020, PostgreSQL Global Development Group
+#
+# src/test/thread/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/tools/thread
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+override CFLAGS += $(PTHREAD_CFLAGS)
+
+all: thread_test
+
+thread_test: thread_test.o
+# no need for $LIBS, might not be compiled yet
+ $(CC) $(CFLAGS) $^ $(LDFLAGS) $(LDFLAGS_EX) $(PTHREAD_LIBS) -o $@$(X)
+
+clean distclean maintainer-clean:
+ rm -f thread_test$(X) thread_test.o