summaryrefslogtreecommitdiffstats
path: root/third_party/python/appdirs/Dockerfile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/python/appdirs/Dockerfile
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/appdirs/Dockerfile')
-rw-r--r--third_party/python/appdirs/Dockerfile13
1 files changed, 13 insertions, 0 deletions
diff --git a/third_party/python/appdirs/Dockerfile b/third_party/python/appdirs/Dockerfile
new file mode 100644
index 0000000000..93dd737bd6
--- /dev/null
+++ b/third_party/python/appdirs/Dockerfile
@@ -0,0 +1,13 @@
+FROM activestate/activepython:2.7
+
+# For Python3 compact
+RUN apt-get -y update && apt-get -y install python3-setuptools && \
+ apt-get -y clean
+
+WORKDIR /app
+ADD . /app
+RUN python setup.py install && python setup.py test
+RUN python3 setup.py install && python3 setup.py test
+
+RUN python -m appdirs
+RUN python3 -m appdirs