summaryrefslogtreecommitdiffstats
path: root/third_party/python/appdirs/Dockerfile
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/appdirs/Dockerfile')
-rw-r--r--third_party/python/appdirs/Dockerfile13
1 files changed, 13 insertions, 0 deletions
diff --git a/third_party/python/appdirs/Dockerfile b/third_party/python/appdirs/Dockerfile
new file mode 100644
index 0000000000..93dd737bd6
--- /dev/null
+++ b/third_party/python/appdirs/Dockerfile
@@ -0,0 +1,13 @@
+FROM activestate/activepython:2.7
+
+# For Python3 compact
+RUN apt-get -y update && apt-get -y install python3-setuptools && \
+ apt-get -y clean
+
+WORKDIR /app
+ADD . /app
+RUN python setup.py install && python setup.py test
+RUN python3 setup.py install && python3 setup.py test
+
+RUN python -m appdirs
+RUN python3 -m appdirs