summaryrefslogtreecommitdiffstats
path: root/src/doc/man/generated_txt/cargo-run.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/doc/man/generated_txt/cargo-run.txt')
-rw-r--r--src/doc/man/generated_txt/cargo-run.txt271
1 files changed, 271 insertions, 0 deletions
diff --git a/src/doc/man/generated_txt/cargo-run.txt b/src/doc/man/generated_txt/cargo-run.txt
new file mode 100644
index 0000000..fc9112a
--- /dev/null
+++ b/src/doc/man/generated_txt/cargo-run.txt
@@ -0,0 +1,271 @@
+CARGO-RUN(1)
+
+NAME
+ cargo-run — Run the current package
+
+SYNOPSIS
+ cargo run [options] [-- args]
+
+DESCRIPTION
+ Run a binary or example of the local package.
+
+ All the arguments following the two dashes (--) are passed to the binary
+ to run. If you’re passing arguments to both Cargo and the binary, the
+ ones after -- go to the binary, the ones before go to Cargo.
+
+OPTIONS
+ Package Selection
+ By default, the package in the current working directory is selected.
+ The -p flag can be used to choose a different package in a workspace.
+
+ -p spec, --package spec
+ The package to run. See cargo-pkgid(1) for the SPEC format.
+
+ Target Selection
+ When no target selection options are given, cargo run will run the
+ binary target. If there are multiple binary targets, you must pass a
+ target flag to choose one. Or, the default-run field may be specified in
+ the [package] section of Cargo.toml to choose the name of the binary to
+ run by default.
+
+ --bin name
+ Run the specified binary.
+
+ --example name
+ Run the specified example.
+
+ Feature Selection
+ The feature flags allow you to control which features are enabled. When
+ no feature options are given, the default feature is activated for every
+ selected package.
+
+ See the features documentation
+ <https://doc.rust-lang.org/cargo/reference/features.html#command-line-feature-options>
+ for more details.
+
+ -F features, --features features
+ Space or comma separated list of features to activate. Features of
+ workspace members may be enabled with package-name/feature-name
+ syntax. This flag may be specified multiple times, which enables all
+ specified features.
+
+ --all-features
+ Activate all available features of all selected packages.
+
+ --no-default-features
+ Do not activate the default feature of the selected packages.
+
+ Compilation Options
+ --target triple
+ Run for the given architecture. The default is the host
+ architecture. The general format of the triple is
+ <arch><sub>-<vendor>-<sys>-<abi>. Run rustc --print target-list for
+ a list of supported targets.
+
+ This may also be specified with the build.target config value
+ <https://doc.rust-lang.org/cargo/reference/config.html>.
+
+ Note that specifying this flag makes Cargo run in a different mode
+ where the target artifacts are placed in a separate directory. See
+ the build cache
+ <https://doc.rust-lang.org/cargo/guide/build-cache.html>
+ documentation for more details.
+
+ -r, --release
+ Run optimized artifacts with the release profile. See also the
+ --profile option for choosing a specific profile by name.
+
+ --profile name
+ Run with the given profile. See the the reference
+ <https://doc.rust-lang.org/cargo/reference/profiles.html> for more
+ details on profiles.
+
+ --ignore-rust-version
+ Run the target even if the selected Rust compiler is older than the
+ required Rust version as configured in the project’s rust-version
+ field.
+
+ --timings=fmts
+ Output information how long each compilation takes, and track
+ concurrency information over time. Accepts an optional
+ comma-separated list of output formats; --timings without an
+ argument will default to --timings=html. Specifying an output format
+ (rather than the default) is unstable and requires
+ -Zunstable-options. Valid output formats:
+
+ o html (unstable, requires -Zunstable-options): Write a
+ human-readable file cargo-timing.html to the target/cargo-timings
+ directory with a report of the compilation. Also write a report
+ to the same directory with a timestamp in the filename if you
+ want to look at older runs. HTML output is suitable for human
+ consumption only, and does not provide machine-readable timing
+ data.
+
+ o json (unstable, requires -Zunstable-options): Emit
+ machine-readable JSON information about timing information.
+
+ Output Options
+ --target-dir directory
+ Directory for all generated artifacts and intermediate files. May
+ also be specified with the CARGO_TARGET_DIR environment variable, or
+ the build.target-dir config value
+ <https://doc.rust-lang.org/cargo/reference/config.html>. Defaults to
+ target in the root of the workspace.
+
+ Display Options
+ -v, --verbose
+ Use verbose output. May be specified twice for “very verbose”
+ output which includes extra output such as dependency warnings and
+ build script output. May also be specified with the term.verbose
+ config value
+ <https://doc.rust-lang.org/cargo/reference/config.html>.
+
+ -q, --quiet
+ Do not print cargo log messages. May also be specified with the
+ term.quiet config value
+ <https://doc.rust-lang.org/cargo/reference/config.html>.
+
+ --color when
+ Control when colored output is used. Valid values:
+
+ o auto (default): Automatically detect if color support is
+ available on the terminal.
+
+ o always: Always display colors.
+
+ o never: Never display colors.
+
+ May also be specified with the term.color config value
+ <https://doc.rust-lang.org/cargo/reference/config.html>.
+
+ --message-format fmt
+ The output format for diagnostic messages. Can be specified multiple
+ times and consists of comma-separated values. Valid values:
+
+ o human (default): Display in a human-readable text format.
+ Conflicts with short and json.
+
+ o short: Emit shorter, human-readable text messages. Conflicts with
+ human and json.
+
+ o json: Emit JSON messages to stdout. See the reference
+ <https://doc.rust-lang.org/cargo/reference/external-tools.html#json-messages>
+ for more details. Conflicts with human and short.
+
+ o json-diagnostic-short: Ensure the rendered field of JSON messages
+ contains the “short” rendering from rustc. Cannot be used
+ with human or short.
+
+ o json-diagnostic-rendered-ansi: Ensure the rendered field of JSON
+ messages contains embedded ANSI color codes for respecting
+ rustc’s default color scheme. Cannot be used with human or
+ short.
+
+ o json-render-diagnostics: Instruct Cargo to not include rustc
+ diagnostics in JSON messages printed, but instead Cargo itself
+ should render the JSON diagnostics coming from rustc. Cargo’s
+ own JSON diagnostics and others coming from rustc are still
+ emitted. Cannot be used with human or short.
+
+ Manifest Options
+ --manifest-path path
+ Path to the Cargo.toml file. By default, Cargo searches for the
+ Cargo.toml file in the current directory or any parent directory.
+
+ --frozen, --locked
+ Either of these flags requires that the Cargo.lock file is
+ up-to-date. If the lock file is missing, or it needs to be updated,
+ Cargo will exit with an error. The --frozen flag also prevents Cargo
+ from attempting to access the network to determine if it is
+ out-of-date.
+
+ These may be used in environments where you want to assert that the
+ Cargo.lock file is up-to-date (such as a CI build) or want to avoid
+ network access.
+
+ --offline
+ Prevents Cargo from accessing the network for any reason. Without
+ this flag, Cargo will stop with an error if it needs to access the
+ network and the network is not available. With this flag, Cargo will
+ attempt to proceed without the network if possible.
+
+ Beware that this may result in different dependency resolution than
+ online mode. Cargo will restrict itself to crates that are
+ downloaded locally, even if there might be a newer version as
+ indicated in the local copy of the index. See the cargo-fetch(1)
+ command to download dependencies before going offline.
+
+ May also be specified with the net.offline config value
+ <https://doc.rust-lang.org/cargo/reference/config.html>.
+
+ Common Options
+ +toolchain
+ If Cargo has been installed with rustup, and the first argument to
+ cargo begins with +, it will be interpreted as a rustup toolchain
+ name (such as +stable or +nightly). See the rustup documentation
+ <https://rust-lang.github.io/rustup/overrides.html> for more
+ information about how toolchain overrides work.
+
+ --config KEY=VALUE or PATH
+ Overrides a Cargo configuration value. The argument should be in
+ TOML syntax of KEY=VALUE, or provided as a path to an extra
+ configuration file. This flag may be specified multiple times. See
+ the command-line overrides section
+ <https://doc.rust-lang.org/cargo/reference/config.html#command-line-overrides>
+ for more information.
+
+ -C PATH
+ Changes the current working directory before executing any specified
+ operations. This affects things like where cargo looks by default
+ for the project manifest (Cargo.toml), as well as the directories
+ searched for discovering .cargo/config.toml, for example.
+
+ This option is only available on the nightly channel
+ <https://doc.rust-lang.org/book/appendix-07-nightly-rust.html> and
+ requires the -Z unstable-options flag to enable (see #10098
+ <https://github.com/rust-lang/cargo/issues/10098>).
+
+ -h, --help
+ Prints help information.
+
+ -Z flag
+ Unstable (nightly-only) flags to Cargo. Run cargo -Z help for
+ details.
+
+ Miscellaneous Options
+ -j N, --jobs N
+ Number of parallel jobs to run. May also be specified with the
+ build.jobs config value
+ <https://doc.rust-lang.org/cargo/reference/config.html>. Defaults to
+ the number of logical CPUs. If negative, it sets the maximum number
+ of parallel jobs to the number of logical CPUs plus provided value.
+ Should not be 0.
+
+ --keep-going
+ Build as many crates in the dependency graph as possible, rather
+ than aborting the build on the first one that fails to build.
+ Unstable, requires -Zunstable-options.
+
+ENVIRONMENT
+ See the reference
+ <https://doc.rust-lang.org/cargo/reference/environment-variables.html>
+ for details on environment variables that Cargo reads.
+
+EXIT STATUS
+ o 0: Cargo succeeded.
+
+ o 101: Cargo failed to complete.
+
+EXAMPLES
+ 1. Build the local package and run its main target (assuming only one
+ binary):
+
+ cargo run
+
+ 2. Run an example with extra arguments:
+
+ cargo run --example exname -- --exoption exarg1 exarg2
+
+SEE ALSO
+ cargo(1), cargo-build(1)
+