summaryrefslogtreecommitdiffstats
path: root/vendor/rfc6979/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rfc6979/Cargo.toml')
-rw-r--r--vendor/rfc6979/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/vendor/rfc6979/Cargo.toml b/vendor/rfc6979/Cargo.toml
new file mode 100644
index 0000000..978868c
--- /dev/null
+++ b/vendor/rfc6979/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.61"
+name = "rfc6979"
+version = "0.4.0"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of RFC6979: Deterministic Usage of the
+Digital Signature Algorithm (DSA) and Elliptic Curve Digital Signature Algorithm (ECDSA)
+"""
+readme = "README.md"
+keywords = [
+ "dsa",
+ "ecdsa",
+ "signature",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/signatures/tree/master/rfc6979"
+
+[dependencies.hmac]
+version = "0.12"
+features = ["reset"]
+default-features = false
+
+[dependencies.subtle]
+version = "2"
+default-features = false
+
+[dev-dependencies.hex-literal]
+version = "0.4"
+
+[dev-dependencies.sha2]
+version = "0.10"