summaryrefslogtreecommitdiffstats
path: root/vendor/rfc6979
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rfc6979')
-rw-r--r--vendor/rfc6979/.cargo-checksum.json1
-rw-r--r--vendor/rfc6979/CHANGELOG.md40
-rw-r--r--vendor/rfc6979/Cargo.toml48
-rw-r--r--vendor/rfc6979/LICENSE-APACHE201
-rw-r--r--vendor/rfc6979/LICENSE-MIT25
-rw-r--r--vendor/rfc6979/README.md55
-rw-r--r--vendor/rfc6979/debian/patches/relax-test-deps.patch13
-rw-r--r--vendor/rfc6979/debian/patches/series1
-rw-r--r--vendor/rfc6979/src/ct_cmp.rs87
-rw-r--r--vendor/rfc6979/src/lib.rs149
-rw-r--r--vendor/rfc6979/tests/lib.rs14
11 files changed, 634 insertions, 0 deletions
diff --git a/vendor/rfc6979/.cargo-checksum.json b/vendor/rfc6979/.cargo-checksum.json
new file mode 100644
index 0000000..056dc41
--- /dev/null
+++ b/vendor/rfc6979/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{},"package":"f8dd2a808d456c4a54e300a23e9f5a67e122c3024119acbfd73e3bf664491cb2"} \ No newline at end of file
diff --git a/vendor/rfc6979/CHANGELOG.md b/vendor/rfc6979/CHANGELOG.md
new file mode 100644
index 0000000..8cc1a0d
--- /dev/null
+++ b/vendor/rfc6979/CHANGELOG.md
@@ -0,0 +1,40 @@
+# Changelog
+All notable changes to this project will be documented in this file.
+
+The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
+and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+
+## 0.4.0 (2023-02-28)
+### Changed
+- MSRV 1.60 ([#628])
+- Decouple from `crypto-bigint` ([#639])
+
+[#628]: https://github.com/RustCrypto/signatures/pull/628
+[#639]: https://github.com/RustCrypto/signatures/pull/639
+
+## 0.3.1 (2022-11-03)
+### Added
+- Usage example ([#577])
+
+[#577]: https://github.com/RustCrypto/signatures/pull/577
+
+## 0.3.0 (2022-06-26)
+### Changed
+- Use `SimpleHmac` to implement `HmacDrbg` ([#499])
+
+[#499]: https://github.com/RustCrypto/signatures/pull/499
+
+## 0.2.0 (2022-05-08)
+### Added
+- License files ([#447])
+
+### Changed
+- Bump `hmac` dependency to v0.12 ([#433])
+- Bump `crypto-bigint` dependency to v0.4 ([#469])
+
+[#433]: https://github.com/RustCrypto/signatures/pull/433
+[#447]: https://github.com/RustCrypto/signatures/pull/447
+[#469]: https://github.com/RustCrypto/signatures/pull/469
+
+### 0.1.0 (2021-11-21)
+- Initial release
diff --git a/vendor/rfc6979/Cargo.toml b/vendor/rfc6979/Cargo.toml
new file mode 100644
index 0000000..978868c
--- /dev/null
+++ b/vendor/rfc6979/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.61"
+name = "rfc6979"
+version = "0.4.0"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of RFC6979: Deterministic Usage of the
+Digital Signature Algorithm (DSA) and Elliptic Curve Digital Signature Algorithm (ECDSA)
+"""
+readme = "README.md"
+keywords = [
+ "dsa",
+ "ecdsa",
+ "signature",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/signatures/tree/master/rfc6979"
+
+[dependencies.hmac]
+version = "0.12"
+features = ["reset"]
+default-features = false
+
+[dependencies.subtle]
+version = "2"
+default-features = false
+
+[dev-dependencies.hex-literal]
+version = "0.4"
+
+[dev-dependencies.sha2]
+version = "0.10"
diff --git a/vendor/rfc6979/LICENSE-APACHE b/vendor/rfc6979/LICENSE-APACHE
new file mode 100644
index 0000000..c394d8a
--- /dev/null
+++ b/vendor/rfc6979/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright 2018-2022 RustCrypto Developers
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/rfc6979/LICENSE-MIT b/vendor/rfc6979/LICENSE-MIT
new file mode 100644
index 0000000..81a3d57
--- /dev/null
+++ b/vendor/rfc6979/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2018-2022 RustCrypto Developers
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/rfc6979/README.md b/vendor/rfc6979/README.md
new file mode 100644
index 0000000..de70e3d
--- /dev/null
+++ b/vendor/rfc6979/README.md
@@ -0,0 +1,55 @@
+# [RustCrypto]: RFC6979 Deterministic Signatures
+
+[![crate][crate-image]][crate-link]
+[![Docs][docs-image]][docs-link]
+[![Build Status][build-image]][build-link]
+![Apache2/MIT licensed][license-image]
+![MSRV][rustc-image]
+[![Project Chat][chat-image]][chat-link]
+
+Pure Rust implementation of RFC6979: Deterministic Usage of the
+Digital Signature Algorithm (DSA) and Elliptic Curve Digital Signature Algorithm (ECDSA).
+
+Algorithm described in RFC 6979 ยง 3.2:
+<https://tools.ietf.org/html/rfc6979#section-3>
+
+[Documentation][docs-link]
+
+## Minimum Supported Rust Version
+
+This crate requires **Rust 1.61** at a minimum.
+
+We may change the MSRV in the future, but it will be accompanied by a minor
+version bump.
+
+## License
+
+All crates licensed under either of
+
+ * [Apache License, Version 2.0](http://www.apache.org/licenses/LICENSE-2.0)
+ * [MIT license](http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in the work by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.
+
+[//]: # (badges)
+
+[crate-image]: https://buildstats.info/crate/rfc6979
+[crate-link]: https://crates.io/crates/rfc6979
+[docs-image]: https://docs.rs/rfc6979/badge.svg
+[docs-link]: https://docs.rs/rfc6979/
+[build-image]: https://github.com/RustCrypto/signatures/actions/workflows/rfc6979.yml/badge.svg
+[build-link]: https://github.com/RustCrypto/signatures/actions/workflows/rfc6979.yml
+[license-image]: https://img.shields.io/badge/license-Apache2.0/MIT-blue.svg
+[rustc-image]: https://img.shields.io/badge/rustc-1.61+-blue.svg
+[chat-image]: https://img.shields.io/badge/zulip-join_chat-blue.svg
+[chat-link]: https://rustcrypto.zulipchat.com/#narrow/stream/260048-signatures
+
+[//]: # (links)
+
+[RustCrypto]: https://github.com/RustCrypto
diff --git a/vendor/rfc6979/debian/patches/relax-test-deps.patch b/vendor/rfc6979/debian/patches/relax-test-deps.patch
new file mode 100644
index 0000000..f620ddd
--- /dev/null
+++ b/vendor/rfc6979/debian/patches/relax-test-deps.patch
@@ -0,0 +1,13 @@
+Index: rfc6979/Cargo.toml
+===================================================================
+--- rfc6979.orig/Cargo.toml
++++ rfc6979/Cargo.toml
+@@ -42,7 +42,7 @@ version = "2"
+ default-features = false
+
+ [dev-dependencies.hex-literal]
+-version = "0.3"
++version = "0.4"
+
+ [dev-dependencies.sha2]
+ version = "0.10"
diff --git a/vendor/rfc6979/debian/patches/series b/vendor/rfc6979/debian/patches/series
new file mode 100644
index 0000000..d304b8f
--- /dev/null
+++ b/vendor/rfc6979/debian/patches/series
@@ -0,0 +1 @@
+relax-test-deps.patch
diff --git a/vendor/rfc6979/src/ct_cmp.rs b/vendor/rfc6979/src/ct_cmp.rs
new file mode 100644
index 0000000..8b216e6
--- /dev/null
+++ b/vendor/rfc6979/src/ct_cmp.rs
@@ -0,0 +1,87 @@
+//! Constant-time comparison helpers for [`ByteArray`].
+
+use crate::{ArrayLength, ByteArray};
+use subtle::{Choice, ConditionallySelectable, ConstantTimeEq};
+
+/// Constant-time equals.
+pub(crate) fn ct_eq<N: ArrayLength<u8>>(a: &ByteArray<N>, b: &ByteArray<N>) -> Choice {
+ let mut ret = Choice::from(1);
+
+ for (a, b) in a.iter().zip(b.iter()) {
+ ret.conditional_assign(&Choice::from(0), !a.ct_eq(b));
+ }
+
+ ret
+}
+
+/// Constant-time less than.
+///
+/// Inputs are interpreted as big endian integers.
+pub(crate) fn ct_lt<N: ArrayLength<u8>>(a: &ByteArray<N>, b: &ByteArray<N>) -> Choice {
+ let mut borrow = 0;
+
+ // Perform subtraction with borrow a byte-at-a-time, interpreting a
+ // no-borrow condition as the less-than case
+ for (&a, &b) in a.iter().zip(b.iter()).rev() {
+ let c = (b as u16).wrapping_add(borrow >> (u8::BITS - 1));
+ borrow = (a as u16).wrapping_sub(c) >> u8::BITS as u8;
+ }
+
+ !borrow.ct_eq(&0)
+}
+
+#[cfg(test)]
+mod tests {
+ const A: [u8; 4] = [0, 0, 0, 0];
+ const B: [u8; 4] = [0, 0, 0, 1];
+ const C: [u8; 4] = [0xFF, 0, 0, 0];
+ const D: [u8; 4] = [0xFF, 0, 0, 1];
+ const E: [u8; 4] = [0xFF, 0xFF, 0xFF, 0xFE];
+ const F: [u8; 4] = [0xFF, 0xFF, 0xFF, 0xFF];
+
+ #[test]
+ fn ct_eq() {
+ use super::ct_eq;
+
+ assert_eq!(ct_eq(&A.into(), &A.into()).unwrap_u8(), 1);
+ assert_eq!(ct_eq(&B.into(), &B.into()).unwrap_u8(), 1);
+ assert_eq!(ct_eq(&C.into(), &C.into()).unwrap_u8(), 1);
+ assert_eq!(ct_eq(&D.into(), &D.into()).unwrap_u8(), 1);
+ assert_eq!(ct_eq(&E.into(), &E.into()).unwrap_u8(), 1);
+ assert_eq!(ct_eq(&F.into(), &F.into()).unwrap_u8(), 1);
+
+ assert_eq!(ct_eq(&A.into(), &B.into()).unwrap_u8(), 0);
+ assert_eq!(ct_eq(&C.into(), &D.into()).unwrap_u8(), 0);
+ assert_eq!(ct_eq(&E.into(), &F.into()).unwrap_u8(), 0);
+ }
+
+ #[test]
+ fn ct_lt() {
+ use super::ct_lt;
+
+ assert_eq!(ct_lt(&A.into(), &A.into()).unwrap_u8(), 0);
+ assert_eq!(ct_lt(&B.into(), &B.into()).unwrap_u8(), 0);
+ assert_eq!(ct_lt(&C.into(), &C.into()).unwrap_u8(), 0);
+ assert_eq!(ct_lt(&D.into(), &D.into()).unwrap_u8(), 0);
+ assert_eq!(ct_lt(&E.into(), &E.into()).unwrap_u8(), 0);
+ assert_eq!(ct_lt(&F.into(), &F.into()).unwrap_u8(), 0);
+
+ assert_eq!(ct_lt(&A.into(), &B.into()).unwrap_u8(), 1);
+ assert_eq!(ct_lt(&A.into(), &C.into()).unwrap_u8(), 1);
+ assert_eq!(ct_lt(&B.into(), &A.into()).unwrap_u8(), 0);
+ assert_eq!(ct_lt(&C.into(), &A.into()).unwrap_u8(), 0);
+
+ assert_eq!(ct_lt(&B.into(), &C.into()).unwrap_u8(), 1);
+ assert_eq!(ct_lt(&B.into(), &D.into()).unwrap_u8(), 1);
+ assert_eq!(ct_lt(&C.into(), &B.into()).unwrap_u8(), 0);
+ assert_eq!(ct_lt(&D.into(), &B.into()).unwrap_u8(), 0);
+
+ assert_eq!(ct_lt(&C.into(), &D.into()).unwrap_u8(), 1);
+ assert_eq!(ct_lt(&C.into(), &E.into()).unwrap_u8(), 1);
+ assert_eq!(ct_lt(&D.into(), &C.into()).unwrap_u8(), 0);
+ assert_eq!(ct_lt(&E.into(), &C.into()).unwrap_u8(), 0);
+
+ assert_eq!(ct_lt(&E.into(), &F.into()).unwrap_u8(), 1);
+ assert_eq!(ct_lt(&F.into(), &E.into()).unwrap_u8(), 0);
+ }
+}
diff --git a/vendor/rfc6979/src/lib.rs b/vendor/rfc6979/src/lib.rs
new file mode 100644
index 0000000..817dda1
--- /dev/null
+++ b/vendor/rfc6979/src/lib.rs
@@ -0,0 +1,149 @@
+#![no_std]
+#![doc = include_str!("../README.md")]
+#![forbid(unsafe_code, clippy::unwrap_used)]
+#![warn(missing_docs, rust_2018_idioms)]
+#![doc(
+ html_logo_url = "https://raw.githubusercontent.com/RustCrypto/media/8f1a9894/logo.svg",
+ html_favicon_url = "https://raw.githubusercontent.com/RustCrypto/media/8f1a9894/logo.svg"
+)]
+
+//! ## Usage
+//!
+//! See also: the documentation for the [`generate_k`] function.
+//!
+//! ```
+//! use hex_literal::hex;
+//! use rfc6979::consts::U32;
+//! use sha2::{Digest, Sha256};
+//!
+//! // NIST P-256 field modulus
+//! const NIST_P256_MODULUS: [u8; 32] =
+//! hex!("FFFFFFFF00000000FFFFFFFFFFFFFFFFBCE6FAADA7179E84F3B9CAC2FC632551");
+//!
+//! // Public key for RFC6979 NIST P256/SHA256 test case
+//! const RFC6979_KEY: [u8; 32] =
+//! hex!("C9AFA9D845BA75166B5C215767B1D6934E50C3DB36E89B127B8A622B120F6721");
+//!
+//! // Test message for RFC6979 NIST P256/SHA256 test case
+//! const RFC6979_MSG: &[u8; 6] = b"sample";
+//!
+//! // Expected K for RFC6979 NIST P256/SHA256 test case
+//! const RFC6979_EXPECTED_K: [u8; 32] =
+//! hex!("A6E3C57DD01ABE90086538398355DD4C3B17AA873382B0F24D6129493D8AAD60");
+//!
+//! let h = Sha256::digest(RFC6979_MSG);
+//! let aad = b"";
+//! let k = rfc6979::generate_k::<Sha256, U32>(&RFC6979_KEY.into(), &NIST_P256_MODULUS.into(), &h, aad);
+//! assert_eq!(k.as_slice(), &RFC6979_EXPECTED_K);
+//! ```
+
+mod ct_cmp;
+
+pub use hmac::digest::generic_array::typenum::consts;
+
+use hmac::{
+ digest::{
+ core_api::BlockSizeUser,
+ generic_array::{ArrayLength, GenericArray},
+ Digest, FixedOutput, FixedOutputReset, Mac,
+ },
+ SimpleHmac,
+};
+
+/// Array of bytes representing a scalar serialized as a big endian integer.
+pub type ByteArray<Size> = GenericArray<u8, Size>;
+
+/// Deterministically generate ephemeral scalar `k`.
+///
+/// Accepts the following parameters and inputs:
+///
+/// - `x`: secret key
+/// - `n`: field modulus
+/// - `h`: hash/digest of input message: must be reduced modulo `n` in advance
+/// - `data`: additional associated data, e.g. CSRNG output used as added entropy
+#[inline]
+pub fn generate_k<D, N>(
+ x: &ByteArray<N>,
+ n: &ByteArray<N>,
+ h: &ByteArray<N>,
+ data: &[u8],
+) -> ByteArray<N>
+where
+ D: Digest + BlockSizeUser + FixedOutput<OutputSize = N> + FixedOutputReset,
+ N: ArrayLength<u8>,
+{
+ let mut hmac_drbg = HmacDrbg::<D>::new(x, h, data);
+
+ loop {
+ let mut k = ByteArray::<N>::default();
+ hmac_drbg.fill_bytes(&mut k);
+
+ let k_is_zero = ct_cmp::ct_eq(&k, &ByteArray::default());
+ if (!k_is_zero & ct_cmp::ct_lt(&k, n)).into() {
+ return k;
+ }
+ }
+}
+
+/// Internal implementation of `HMAC_DRBG` as described in NIST SP800-90A.
+///
+/// <https://csrc.nist.gov/publications/detail/sp/800-90a/rev-1/final>
+///
+/// This is a HMAC-based deterministic random bit generator used compute a
+/// deterministic ephemeral scalar `k`.
+pub struct HmacDrbg<D>
+where
+ D: Digest + BlockSizeUser + FixedOutputReset,
+{
+ /// HMAC key `K` (see RFC 6979 Section 3.2.c)
+ k: SimpleHmac<D>,
+
+ /// Chaining value `V` (see RFC 6979 Section 3.2.c)
+ v: GenericArray<u8, D::OutputSize>,
+}
+
+impl<D> HmacDrbg<D>
+where
+ D: Digest + BlockSizeUser + FixedOutputReset,
+{
+ /// Initialize `HMAC_DRBG`
+ pub fn new(entropy_input: &[u8], nonce: &[u8], additional_data: &[u8]) -> Self {
+ let mut k = SimpleHmac::new(&Default::default());
+ let mut v = GenericArray::default();
+
+ for b in &mut v {
+ *b = 0x01;
+ }
+
+ for i in 0..=1 {
+ k.update(&v);
+ k.update(&[i]);
+ k.update(entropy_input);
+ k.update(nonce);
+ k.update(additional_data);
+ k = SimpleHmac::new_from_slice(&k.finalize().into_bytes()).expect("HMAC error");
+
+ // Steps 3.2.e,g: v = HMAC_k(v)
+ k.update(&v);
+ v = k.finalize_reset().into_bytes();
+ }
+
+ Self { k, v }
+ }
+
+ /// Write the next `HMAC_DRBG` output to the given byte slice.
+ pub fn fill_bytes(&mut self, out: &mut [u8]) {
+ for out_chunk in out.chunks_mut(self.v.len()) {
+ self.k.update(&self.v);
+ self.v = self.k.finalize_reset().into_bytes();
+ out_chunk.copy_from_slice(&self.v[..out_chunk.len()]);
+ }
+
+ self.k.update(&self.v);
+ self.k.update(&[0x00]);
+ self.k =
+ SimpleHmac::new_from_slice(&self.k.finalize_reset().into_bytes()).expect("HMAC error");
+ self.k.update(&self.v);
+ self.v = self.k.finalize_reset().into_bytes();
+ }
+}
diff --git a/vendor/rfc6979/tests/lib.rs b/vendor/rfc6979/tests/lib.rs
new file mode 100644
index 0000000..1b622f8
--- /dev/null
+++ b/vendor/rfc6979/tests/lib.rs
@@ -0,0 +1,14 @@
+//! Smoke tests which use `MockCurve`
+
+#![cfg(feature = "dev")]
+
+use elliptic_curve::dev::MockCurve;
+
+type Signature = ecdsa::Signature<MockCurve>;
+type SignatureBytes = ecdsa::SignatureBytes<MockCurve>;
+
+#[test]
+fn rejects_all_zero_signature() {
+ let all_zero_bytes = SignatureBytes::default();
+ assert!(Signature::try_from(all_zero_bytes.as_ref()).is_err());
+}