summaryrefslogtreecommitdiffstats
path: root/config/makefiles
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
commitfbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8 (patch)
tree4c1ccaf5486d4f2009f9a338a98a83e886e29c97 /config/makefiles
parentReleasing progress-linux version 124.0.1-1~progress7.99u1. (diff)
downloadfirefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.tar.xz
firefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'config/makefiles')
-rw-r--r--config/makefiles/rust.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
index 9e3d5256b9..b10594f5cb 100644
--- a/config/makefiles/rust.mk
+++ b/config/makefiles/rust.mk
@@ -252,6 +252,12 @@ ifeq ($(OS_ARCH), Darwin)
ifdef MACOS_SDK_DIR
export COREAUDIO_SDK_PATH=$(MACOS_SDK_DIR)
endif
+ifdef IPHONEOS_SDK_DIR
+export COREAUDIO_SDK_PATH=$(IPHONEOS_SDK_DIR)
+# export for build/macosx/xcrun
+export IPHONEOS_SDK_DIR
+PATH := $(topsrcdir)/build/macosx:$(PATH)
+endif
endif
ifndef RUSTC_BOOTSTRAP