summaryrefslogtreecommitdiffstats
path: root/config/makefiles
diff options
context:
space:
mode:
Diffstat (limited to 'config/makefiles')
-rw-r--r--config/makefiles/rust.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
index 9e3d5256b9..b10594f5cb 100644
--- a/config/makefiles/rust.mk
+++ b/config/makefiles/rust.mk
@@ -252,6 +252,12 @@ ifeq ($(OS_ARCH), Darwin)
ifdef MACOS_SDK_DIR
export COREAUDIO_SDK_PATH=$(MACOS_SDK_DIR)
endif
+ifdef IPHONEOS_SDK_DIR
+export COREAUDIO_SDK_PATH=$(IPHONEOS_SDK_DIR)
+# export for build/macosx/xcrun
+export IPHONEOS_SDK_DIR
+PATH := $(topsrcdir)/build/macosx:$(PATH)
+endif
endif
ifndef RUSTC_BOOTSTRAP