summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/src/frame.spec.ts
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
commitfbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8 (patch)
tree4c1ccaf5486d4f2009f9a338a98a83e886e29c97 /remote/test/puppeteer/test/src/frame.spec.ts
parentReleasing progress-linux version 124.0.1-1~progress7.99u1. (diff)
downloadfirefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.tar.xz
firefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remote/test/puppeteer/test/src/frame.spec.ts')
-rw-r--r--remote/test/puppeteer/test/src/frame.spec.ts12
1 files changed, 12 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test/src/frame.spec.ts b/remote/test/puppeteer/test/src/frame.spec.ts
index 3b2456821a..a49fb19482 100644
--- a/remote/test/puppeteer/test/src/frame.spec.ts
+++ b/remote/test/puppeteer/test/src/frame.spec.ts
@@ -205,6 +205,18 @@ describe('Frame specs', function () {
expect(detachedFrames).toHaveLength(4);
expect(navigatedFrames).toHaveLength(1);
});
+
+ it('should click elements in a frameset', async () => {
+ const {page, server} = await getTestState();
+ await page.goto(server.PREFIX + '/frames/frameset.html');
+ const frame = await page.waitForFrame(frame => {
+ return frame.url().endsWith('/frames/frame.html');
+ });
+ using div = await frame.waitForSelector('div');
+ expect(div).toBeTruthy();
+ await div?.click();
+ });
+
it('should report frame from-inside shadow DOM', async () => {
const {page, server} = await getTestState();