summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/src/frame.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'remote/test/puppeteer/test/src/frame.spec.ts')
-rw-r--r--remote/test/puppeteer/test/src/frame.spec.ts12
1 files changed, 12 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test/src/frame.spec.ts b/remote/test/puppeteer/test/src/frame.spec.ts
index 3b2456821a..a49fb19482 100644
--- a/remote/test/puppeteer/test/src/frame.spec.ts
+++ b/remote/test/puppeteer/test/src/frame.spec.ts
@@ -205,6 +205,18 @@ describe('Frame specs', function () {
expect(detachedFrames).toHaveLength(4);
expect(navigatedFrames).toHaveLength(1);
});
+
+ it('should click elements in a frameset', async () => {
+ const {page, server} = await getTestState();
+ await page.goto(server.PREFIX + '/frames/frameset.html');
+ const frame = await page.waitForFrame(frame => {
+ return frame.url().endsWith('/frames/frame.html');
+ });
+ using div = await frame.waitForSelector('div');
+ expect(div).toBeTruthy();
+ await div?.click();
+ });
+
it('should report frame from-inside shadow DOM', async () => {
const {page, server} = await getTestState();