summaryrefslogtreecommitdiffstats
path: root/third_party/rust/android_logger
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/android_logger
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/android_logger')
-rw-r--r--third_party/rust/android_logger/.cargo-checksum.json1
-rw-r--r--third_party/rust/android_logger/CHANGELOG.md54
-rw-r--r--third_party/rust/android_logger/Cargo.toml48
-rw-r--r--third_party/rust/android_logger/LICENSE-APACHE201
-rw-r--r--third_party/rust/android_logger/LICENSE-MIT19
-rw-r--r--third_party/rust/android_logger/README.md82
-rw-r--r--third_party/rust/android_logger/src/lib.rs670
-rw-r--r--third_party/rust/android_logger/tests/config_log_level.rs11
-rw-r--r--third_party/rust/android_logger/tests/default_init.rs10
-rw-r--r--third_party/rust/android_logger/tests/multiple_init.rs16
10 files changed, 1112 insertions, 0 deletions
diff --git a/third_party/rust/android_logger/.cargo-checksum.json b/third_party/rust/android_logger/.cargo-checksum.json
new file mode 100644
index 0000000000..5f65e63940
--- /dev/null
+++ b/third_party/rust/android_logger/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"CHANGELOG.md":"66faf0eef7c262a90a0538248c0753b5bb7f6f38df086a3701db1590cc0e81a3","Cargo.toml":"35882b3da778c3a4464967f6142579b1378a4ab9ff83adebb151a606c5fdd9ed","LICENSE-APACHE":"99938c5864dd33decb62ab20fd883a9b00181d768ae887a4f19b2d0015c41dc9","LICENSE-MIT":"35043211d1b7be8f7e3f9cad27d981f2189ba9a39d9527b275b3c9740298dfe2","README.md":"dbdb2a11c4a49ec21259d611af2de6123fa9b3f467950eb7a5af163f8aea556b","src/lib.rs":"f820afaf0c15160756128018fb6eac94f74a8cf6359168346354d120c1204532","tests/config_log_level.rs":"61f12ee69f0a7e0e6c2b224d4b678f384ca0ee75122e62c01a9f75dbd9ba4437","tests/default_init.rs":"e5c77dbcf3dc2d9e21e5c48c190e6cdcdea7d8eecea8c8ce513ca98223c46b49","tests/multiple_init.rs":"b5fa06a0b92843227ecbb6285bdf7ab826412fd2fe11fac8b1fd68a7354fd3ee"},"package":"037f3e1da32ddba7770530e69258b742c15ad67bdf90e5f6b35f4b6db9a60eb7"} \ No newline at end of file
diff --git a/third_party/rust/android_logger/CHANGELOG.md b/third_party/rust/android_logger/CHANGELOG.md
new file mode 100644
index 0000000000..4952ca18b5
--- /dev/null
+++ b/third_party/rust/android_logger/CHANGELOG.md
@@ -0,0 +1,54 @@
+`android_logger` changelog
+==========================
+
+All user visible changes to this project will be documented in this file. This project uses [Semantic Versioning 2.0.0].
+
+
+
+
+## [0.12.0] · 2023-01-19
+[0.12.0]: /../../tree/v0.12.0
+
+[Diff](/../../compare/v0.11.3...v0.12.0)
+
+### Added
+
+- `Config::with_max_level()` method to filters logs via `log::LevelFilter`. ([#62])
+
+### Deprecated
+
+- `Config::with_min_level()` method accepting `log::Level`. ([#62])
+
+### Fixed
+
+- Incorrect logs level filtering. ([#62])
+
+[#62]: /../../pull/62
+
+
+
+
+## [0.11.3] · 2022-12-20
+[0.11.3]: /../../tree/v0.11.3
+
+[Diff](/../../compare/38186ece1056d90b8f75fd2a5eb5c860e0a1704e...v0.11.3)
+
+### Fixed
+
+- Broken compilation on [Android] targets. ([#59], [#58])
+
+[#58]: /../../issues/58
+[#59]: /../../pull/59
+
+
+
+
+## Previous releases
+
+See [Git log](/../../commits/master?after=1a5a07ec6742f0069acc2be223c1bb3b6a9d15f8+0).
+
+
+
+
+[Android]: https://www.android.com
+[Semantic Versioning 2.0.0]: https://semver.org
diff --git a/third_party/rust/android_logger/Cargo.toml b/third_party/rust/android_logger/Cargo.toml
new file mode 100644
index 0000000000..a9fd573be2
--- /dev/null
+++ b/third_party/rust/android_logger/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "android_logger"
+version = "0.12.0"
+authors = ["The android_logger Developers"]
+description = """
+A logging implementation for `log` which hooks to android log output.
+"""
+readme = "README.md"
+keywords = [
+ "android",
+ "bindings",
+ "log",
+ "logger",
+]
+categories = ["api-bindings"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Nercury/android_logger-rs"
+
+[dependencies.android_log-sys]
+version = "0.2"
+
+[dependencies.env_logger]
+version = "0.10"
+default-features = false
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.once_cell]
+version = "1.9"
+
+[features]
+default = ["regex"]
+regex = ["env_logger/regex"]
+
+[badges.travis-ci]
+repository = "Nercury/android_logger-rs"
diff --git a/third_party/rust/android_logger/LICENSE-APACHE b/third_party/rust/android_logger/LICENSE-APACHE
new file mode 100644
index 0000000000..36b2b450cd
--- /dev/null
+++ b/third_party/rust/android_logger/LICENSE-APACHE
@@ -0,0 +1,201 @@
+Apache License
+Version 2.0, January 2004
+http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+"License" shall mean the terms and conditions for use, reproduction,
+and distribution as defined by Sections 1 through 9 of this document.
+
+"Licensor" shall mean the copyright owner or entity authorized by
+the copyright owner that is granting the License.
+
+"Legal Entity" shall mean the union of the acting entity and all
+other entities that control, are controlled by, or are under common
+control with that entity. For the purposes of this definition,
+"control" means (i) the power, direct or indirect, to cause the
+direction or management of such entity, whether by contract or
+otherwise, or (ii) ownership of fifty percent (50%) or more of the
+outstanding shares, or (iii) beneficial ownership of such entity.
+
+"You" (or "Your") shall mean an individual or Legal Entity
+exercising permissions granted by this License.
+
+"Source" form shall mean the preferred form for making modifications,
+including but not limited to software source code, documentation
+source, and configuration files.
+
+"Object" form shall mean any form resulting from mechanical
+transformation or translation of a Source form, including but
+not limited to compiled object code, generated documentation,
+and conversions to other media types.
+
+"Work" shall mean the work of authorship, whether in Source or
+Object form, made available under the License, as indicated by a
+copyright notice that is included in or attached to the work
+(an example is provided in the Appendix below).
+
+"Derivative Works" shall mean any work, whether in Source or Object
+form, that is based on (or derived from) the Work and for which the
+editorial revisions, annotations, elaborations, or other modifications
+represent, as a whole, an original work of authorship. For the purposes
+of this License, Derivative Works shall not include works that remain
+separable from, or merely link (or bind by name) to the interfaces of,
+the Work and Derivative Works thereof.
+
+"Contribution" shall mean any work of authorship, including
+the original version of the Work and any modifications or additions
+to that Work or Derivative Works thereof, that is intentionally
+submitted to Licensor for inclusion in the Work by the copyright owner
+or by an individual or Legal Entity authorized to submit on behalf of
+the copyright owner. For the purposes of this definition, "submitted"
+means any form of electronic, verbal, or written communication sent
+to the Licensor or its representatives, including but not limited to
+communication on electronic mailing lists, source code control systems,
+and issue tracking systems that are managed by, or on behalf of, the
+Licensor for the purpose of discussing and improving the Work, but
+excluding communication that is conspicuously marked or otherwise
+designated in writing by the copyright owner as "Not a Contribution."
+
+"Contributor" shall mean Licensor and any individual or Legal Entity
+on behalf of whom a Contribution has been received by Licensor and
+subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+this License, each Contributor hereby grants to You a perpetual,
+worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+copyright license to reproduce, prepare Derivative Works of,
+publicly display, publicly perform, sublicense, and distribute the
+Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+this License, each Contributor hereby grants to You a perpetual,
+worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+(except as stated in this section) patent license to make, have made,
+use, offer to sell, sell, import, and otherwise transfer the Work,
+where such license applies only to those patent claims licensable
+by such Contributor that are necessarily infringed by their
+Contribution(s) alone or by combination of their Contribution(s)
+with the Work to which such Contribution(s) was submitted. If You
+institute patent litigation against any entity (including a
+cross-claim or counterclaim in a lawsuit) alleging that the Work
+or a Contribution incorporated within the Work constitutes direct
+or contributory patent infringement, then any patent licenses
+granted to You under this License for that Work shall terminate
+as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+Work or Derivative Works thereof in any medium, with or without
+modifications, and in Source or Object form, provided that You
+meet the following conditions:
+
+(a) You must give any other recipients of the Work or
+Derivative Works a copy of this License; and
+
+(b) You must cause any modified files to carry prominent notices
+stating that You changed the files; and
+
+(c) You must retain, in the Source form of any Derivative Works
+that You distribute, all copyright, patent, trademark, and
+attribution notices from the Source form of the Work,
+excluding those notices that do not pertain to any part of
+the Derivative Works; and
+
+(d) If the Work includes a "NOTICE" text file as part of its
+distribution, then any Derivative Works that You distribute must
+include a readable copy of the attribution notices contained
+within such NOTICE file, excluding those notices that do not
+pertain to any part of the Derivative Works, in at least one
+of the following places: within a NOTICE text file distributed
+as part of the Derivative Works; within the Source form or
+documentation, if provided along with the Derivative Works; or,
+within a display generated by the Derivative Works, if and
+wherever such third-party notices normally appear. The contents
+of the NOTICE file are for informational purposes only and
+do not modify the License. You may add Your own attribution
+notices within Derivative Works that You distribute, alongside
+or as an addendum to the NOTICE text from the Work, provided
+that such additional attribution notices cannot be construed
+as modifying the License.
+
+You may add Your own copyright statement to Your modifications and
+may provide additional or different license terms and conditions
+for use, reproduction, or distribution of Your modifications, or
+for any such Derivative Works as a whole, provided Your use,
+reproduction, and distribution of the Work otherwise complies with
+the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+any Contribution intentionally submitted for inclusion in the Work
+by You to the Licensor shall be under the terms and conditions of
+this License, without any additional terms or conditions.
+Notwithstanding the above, nothing herein shall supersede or modify
+the terms of any separate license agreement you may have executed
+with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+names, trademarks, service marks, or product names of the Licensor,
+except as required for reasonable and customary use in describing the
+origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+agreed to in writing, Licensor provides the Work (and each
+Contributor provides its Contributions) on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+implied, including, without limitation, any warranties or conditions
+of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+PARTICULAR PURPOSE. You are solely responsible for determining the
+appropriateness of using or redistributing the Work and assume any
+risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+whether in tort (including negligence), contract, or otherwise,
+unless required by applicable law (such as deliberate and grossly
+negligent acts) or agreed to in writing, shall any Contributor be
+liable to You for damages, including any direct, indirect, special,
+incidental, or consequential damages of any character arising as a
+result of this License or out of the use or inability to use the
+Work (including but not limited to damages for loss of goodwill,
+work stoppage, computer failure or malfunction, or any and all
+other commercial damages or losses), even if such Contributor
+has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+the Work or Derivative Works thereof, You may choose to offer,
+and charge a fee for, acceptance of support, warranty, indemnity,
+or other liability obligations and/or rights consistent with this
+License. However, in accepting such obligations, You may act only
+on Your own behalf and on Your sole responsibility, not on behalf
+of any other Contributor, and only if You agree to indemnify,
+defend, and hold each Contributor harmless for any liability
+incurred by, or claims asserted against, such Contributor by reason
+of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+To apply the Apache License to your work, attach the following
+boilerplate notice, with the fields enclosed by brackets "{}"
+replaced with your own identifying information. (Don't include
+the brackets!) The text should be enclosed in the appropriate
+comment syntax for the file format. We also recommend that a
+file or class name and description of purpose be included on the
+same "printed page" as the copyright notice for easier
+identification within third-party archives.
+
+Copyright 2016 The android_logger Developers
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/android_logger/LICENSE-MIT b/third_party/rust/android_logger/LICENSE-MIT
new file mode 100644
index 0000000000..d73e1453ce
--- /dev/null
+++ b/third_party/rust/android_logger/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2016 The android_logger Developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/third_party/rust/android_logger/README.md b/third_party/rust/android_logger/README.md
new file mode 100644
index 0000000000..eec1ebafc5
--- /dev/null
+++ b/third_party/rust/android_logger/README.md
@@ -0,0 +1,82 @@
+## Send Rust logs to Logcat
+
+[![Version](https://img.shields.io/crates/v/android_logger.svg)](https://crates.io/crates/android_logger)
+[![CI status](https://github.com/Nercury/android_logger-rs/actions/workflows/ci.yml/badge.svg)](https://github.com/Nercury/android_logger-rs/actions/workflows/ci.yml/)
+
+
+This library is a drop-in replacement for `env_logger`. Instead, it outputs messages to
+android's logcat.
+
+This only works on Android and requires linking to `log` which
+is only available under android. With Cargo, it is possible to conditionally require
+this library:
+
+```toml
+[target.'cfg(target_os = "android")'.dependencies]
+android_logger = "0.11"
+```
+
+Example of initialization on activity creation, with log configuration:
+
+```rust
+#[macro_use] extern crate log;
+extern crate android_logger;
+
+use log::LevelFilter;
+use android_logger::{Config,FilterBuilder};
+
+fn native_activity_create() {
+ android_logger::init_once(
+ Config::default()
+ .with_max_level(LevelFilter::Trace) // limit log level
+ .with_tag("mytag") // logs will show under mytag tag
+ .with_filter( // configure messages for specific crate
+ FilterBuilder::new()
+ .parse("debug,hello::crate=error")
+ .build())
+ );
+
+ trace!("this is a verbose {}", "message");
+ error!("this is printed by default");
+}
+```
+
+To allow all logs, use the default configuration with min level Trace:
+
+```rust
+#[macro_use] extern crate log;
+extern crate android_logger;
+
+use log::LevelFilter;
+use android_logger::Config;
+
+fn native_activity_create() {
+ android_logger::init_once(
+ Config::default().with_max_level(LevelFilter::Trace),
+ );
+}
+```
+
+There is a caveat that this library can only be initialized once
+(hence the `init_once` function name). However, Android native activity can be
+re-created every time the screen is rotated, resulting in multiple initialization calls.
+Therefore this library will only log a warning for subsequent `init_once` calls.
+
+This library ensures that logged messages do not overflow Android log message limits
+by efficiently splitting messages into chunks.
+
+## License
+
+Licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally
+submitted for inclusion in the work by you, as defined in the Apache-2.0
+license, shall be dual licensed as above, without any additional terms or
+conditions.
diff --git a/third_party/rust/android_logger/src/lib.rs b/third_party/rust/android_logger/src/lib.rs
new file mode 100644
index 0000000000..0446fad755
--- /dev/null
+++ b/third_party/rust/android_logger/src/lib.rs
@@ -0,0 +1,670 @@
+// Copyright 2016 The android_logger Developers
+//
+// Licensed under the Apache License, Version 2.0, <LICENSE-APACHE or
+// http://apache.org/licenses/LICENSE-2.0> or the MIT license <LICENSE-MIT or
+// http://opensource.org/licenses/MIT>, at your option. This file may not be
+// copied, modified, or distributed except according to those terms.
+
+//! A logger which writes to android output.
+//!
+//! ## Example
+//!
+//! ```
+//! #[macro_use] extern crate log;
+//! extern crate android_logger;
+//!
+//! use log::LevelFilter;
+//! use android_logger::Config;
+//!
+//! /// Android code may not have obvious "main", this is just an example.
+//! fn main() {
+//! android_logger::init_once(
+//! Config::default().with_max_level(LevelFilter::Trace),
+//! );
+//!
+//! debug!("this is a debug {}", "message");
+//! error!("this is printed by default");
+//! }
+//! ```
+//!
+//! ## Example with module path filter
+//!
+//! It is possible to limit log messages to output from a specific crate,
+//! and override the logcat tag name (by default, the crate name is used):
+//!
+//! ```
+//! #[macro_use] extern crate log;
+//! extern crate android_logger;
+//!
+//! use log::LevelFilter;
+//! use android_logger::{Config,FilterBuilder};
+//!
+//! fn main() {
+//! android_logger::init_once(
+//! Config::default()
+//! .with_max_level(LevelFilter::Trace)
+//! .with_tag("mytag")
+//! .with_filter(FilterBuilder::new().parse("debug,hello::crate=trace").build()),
+//! );
+//!
+//! // ..
+//! }
+//! ```
+//!
+//! ## Example with a custom log formatter
+//!
+//! ```
+//! use android_logger::Config;
+//!
+//! android_logger::init_once(
+//! Config::default()
+//! .with_max_level(log::LevelFilter::Trace)
+//! .format(|f, record| write!(f, "my_app: {}", record.args()))
+//! )
+//! ```
+
+#[cfg(target_os = "android")]
+extern crate android_log_sys as log_ffi;
+extern crate once_cell;
+use once_cell::sync::OnceCell;
+#[macro_use]
+extern crate log;
+
+extern crate env_logger;
+
+use log::{Level, LevelFilter, Log, Metadata, Record};
+#[cfg(target_os = "android")]
+use log_ffi::LogPriority;
+use std::ffi::{CStr, CString};
+use std::fmt;
+use std::mem::{self, MaybeUninit};
+use std::ptr;
+
+pub use env_logger::filter::{Builder as FilterBuilder, Filter};
+pub use env_logger::fmt::Formatter;
+
+pub(crate) type FormatFn = Box<dyn Fn(&mut dyn fmt::Write, &Record) -> fmt::Result + Sync + Send>;
+
+/// Output log to android system.
+#[cfg(target_os = "android")]
+fn android_log(prio: log_ffi::LogPriority, tag: &CStr, msg: &CStr) {
+ unsafe {
+ log_ffi::__android_log_write(
+ prio as log_ffi::c_int,
+ tag.as_ptr() as *const log_ffi::c_char,
+ msg.as_ptr() as *const log_ffi::c_char,
+ )
+ };
+}
+
+/// Dummy output placeholder for tests.
+#[cfg(not(target_os = "android"))]
+fn android_log(_priority: Level, _tag: &CStr, _msg: &CStr) {}
+
+/// Underlying android logger backend
+pub struct AndroidLogger {
+ config: OnceCell<Config>,
+}
+
+impl AndroidLogger {
+ /// Create new logger instance from config
+ pub fn new(config: Config) -> AndroidLogger {
+ AndroidLogger {
+ config: OnceCell::from(config),
+ }
+ }
+
+ fn config(&self) -> &Config {
+ self.config.get_or_init(Config::default)
+ }
+}
+
+static ANDROID_LOGGER: OnceCell<AndroidLogger> = OnceCell::new();
+
+const LOGGING_TAG_MAX_LEN: usize = 23;
+const LOGGING_MSG_MAX_LEN: usize = 4000;
+
+impl Default for AndroidLogger {
+ /// Create a new logger with default config
+ fn default() -> AndroidLogger {
+ AndroidLogger {
+ config: OnceCell::from(Config::default()),
+ }
+ }
+}
+
+impl Log for AndroidLogger {
+ fn enabled(&self, metadata: &Metadata) -> bool {
+ let config = self.config();
+ // todo: consider __android_log_is_loggable.
+ metadata.level() <= config.log_level.unwrap_or_else(log::max_level)
+ }
+
+ fn log(&self, record: &Record) {
+ let config = self.config();
+
+ if !self.enabled(record.metadata()) {
+ return;
+ }
+
+ // this also checks the level, but only if a filter was
+ // installed.
+ if !config.filter_matches(record) {
+ return;
+ }
+
+ // tag must not exceed LOGGING_TAG_MAX_LEN
+ let mut tag_bytes: [MaybeUninit<u8>; LOGGING_TAG_MAX_LEN + 1] = uninit_array();
+
+ let module_path = record.module_path().unwrap_or_default().to_owned();
+
+ // If no tag was specified, use module name
+ let custom_tag = &config.tag;
+ let tag = custom_tag
+ .as_ref()
+ .map(|s| s.as_bytes())
+ .unwrap_or_else(|| module_path.as_bytes());
+
+ // truncate the tag here to fit into LOGGING_TAG_MAX_LEN
+ self.fill_tag_bytes(&mut tag_bytes, tag);
+ // use stack array as C string
+ let tag: &CStr = unsafe { CStr::from_ptr(mem::transmute(tag_bytes.as_ptr())) };
+
+ // message must not exceed LOGGING_MSG_MAX_LEN
+ // therefore split log message into multiple log calls
+ let mut writer = PlatformLogWriter::new(record.level(), tag);
+
+ // If a custom tag is used, add the module path to the message.
+ // Use PlatformLogWriter to output chunks if they exceed max size.
+ let _ = match (custom_tag, &config.custom_format) {
+ (_, Some(format)) => format(&mut writer, record),
+ (Some(_), _) => fmt::write(
+ &mut writer,
+ format_args!("{}: {}", module_path, *record.args()),
+ ),
+ _ => fmt::write(&mut writer, *record.args()),
+ };
+
+ // output the remaining message (this would usually be the most common case)
+ writer.flush();
+ }
+
+ fn flush(&self) {}
+}
+
+impl AndroidLogger {
+ fn fill_tag_bytes(&self, array: &mut [MaybeUninit<u8>], tag: &[u8]) {
+ if tag.len() > LOGGING_TAG_MAX_LEN {
+ for (input, output) in tag
+ .iter()
+ .take(LOGGING_TAG_MAX_LEN - 2)
+ .chain(b"..\0".iter())
+ .zip(array.iter_mut())
+ {
+ output.write(*input);
+ }
+ } else {
+ for (input, output) in tag.iter().chain(b"\0".iter()).zip(array.iter_mut()) {
+ output.write(*input);
+ }
+ }
+ }
+}
+
+/// Filter for android logger.
+#[derive(Default)]
+pub struct Config {
+ log_level: Option<LevelFilter>,
+ filter: Option<env_logger::filter::Filter>,
+ tag: Option<CString>,
+ custom_format: Option<FormatFn>,
+}
+
+impl Config {
+ // TODO: Remove on 0.13 version release.
+ /// **DEPRECATED**, use [`Config::with_max_level()`] instead.
+ #[deprecated(note = "use `.with_max_level()` instead")]
+ pub fn with_min_level(self, level: Level) -> Self {
+ self.with_max_level(level.to_level_filter())
+ }
+
+ /// Changes the maximum log level.
+ ///
+ /// Note, that `Trace` is the maximum level, because it provides the
+ /// maximum amount of detail in the emitted logs.
+ ///
+ /// If `Off` level is provided, then nothing is logged at all.
+ ///
+ /// [`log::max_level()`] is considered as the default level.
+ pub fn with_max_level(mut self, level: LevelFilter) -> Self {
+ self.log_level = Some(level);
+ self
+ }
+
+ fn filter_matches(&self, record: &Record) -> bool {
+ if let Some(ref filter) = self.filter {
+ filter.matches(record)
+ } else {
+ true
+ }
+ }
+
+ pub fn with_filter(mut self, filter: env_logger::filter::Filter) -> Self {
+ self.filter = Some(filter);
+ self
+ }
+
+ pub fn with_tag<S: Into<Vec<u8>>>(mut self, tag: S) -> Self {
+ self.tag = Some(CString::new(tag).expect("Can't convert tag to CString"));
+ self
+ }
+
+ /// Sets the format function for formatting the log output.
+ /// ```
+ /// # use android_logger::Config;
+ /// android_logger::init_once(
+ /// Config::default()
+ /// .with_max_level(log::LevelFilter::Trace)
+ /// .format(|f, record| write!(f, "my_app: {}", record.args()))
+ /// )
+ /// ```
+ pub fn format<F>(mut self, format: F) -> Self
+ where
+ F: Fn(&mut dyn fmt::Write, &Record) -> fmt::Result + Sync + Send + 'static,
+ {
+ self.custom_format = Some(Box::new(format));
+ self
+ }
+}
+
+pub struct PlatformLogWriter<'a> {
+ #[cfg(target_os = "android")]
+ priority: LogPriority,
+ #[cfg(not(target_os = "android"))]
+ priority: Level,
+ len: usize,
+ last_newline_index: usize,
+ tag: &'a CStr,
+ buffer: [MaybeUninit<u8>; LOGGING_MSG_MAX_LEN + 1],
+}
+
+impl<'a> PlatformLogWriter<'a> {
+ #[cfg(target_os = "android")]
+ pub fn new_with_priority(priority: log_ffi::LogPriority, tag: &CStr) -> PlatformLogWriter {
+ #[allow(deprecated)] // created an issue #35 for this
+ PlatformLogWriter {
+ priority,
+ len: 0,
+ last_newline_index: 0,
+ tag,
+ buffer: uninit_array(),
+ }
+ }
+
+ #[cfg(target_os = "android")]
+ pub fn new(level: Level, tag: &CStr) -> PlatformLogWriter {
+ Self::new_with_priority(
+ match level {
+ Level::Warn => LogPriority::WARN,
+ Level::Info => LogPriority::INFO,
+ Level::Debug => LogPriority::DEBUG,
+ Level::Error => LogPriority::ERROR,
+ Level::Trace => LogPriority::VERBOSE,
+ },
+ tag,
+ )
+ }
+
+ #[cfg(not(target_os = "android"))]
+ pub fn new(level: Level, tag: &CStr) -> PlatformLogWriter {
+ #[allow(deprecated)] // created an issue #35 for this
+ PlatformLogWriter {
+ priority: level,
+ len: 0,
+ last_newline_index: 0,
+ tag,
+ buffer: uninit_array(),
+ }
+ }
+
+ /// Flush some bytes to android logger.
+ ///
+ /// If there is a newline, flush up to it.
+ /// If ther was no newline, flush all.
+ ///
+ /// Not guaranteed to flush everything.
+ fn temporal_flush(&mut self) {
+ let total_len = self.len;
+
+ if total_len == 0 {
+ return;
+ }
+
+ if self.last_newline_index > 0 {
+ let copy_from_index = self.last_newline_index;
+ let remaining_chunk_len = total_len - copy_from_index;
+
+ self.output_specified_len(copy_from_index);
+ self.copy_bytes_to_start(copy_from_index, remaining_chunk_len);
+ self.len = remaining_chunk_len;
+ } else {
+ self.output_specified_len(total_len);
+ self.len = 0;
+ }
+ self.last_newline_index = 0;
+ }
+
+ /// Flush everything remaining to android logger.
+ pub fn flush(&mut self) {
+ let total_len = self.len;
+
+ if total_len == 0 {
+ return;
+ }
+
+ self.output_specified_len(total_len);
+ self.len = 0;
+ self.last_newline_index = 0;
+ }
+
+ /// Output buffer up until the \0 which will be placed at `len` position.
+ fn output_specified_len(&mut self, len: usize) {
+ let mut last_byte = MaybeUninit::new(b'\0');
+
+ mem::swap(&mut last_byte, unsafe {
+ self.buffer.get_unchecked_mut(len)
+ });
+
+ let msg: &CStr = unsafe { CStr::from_ptr(self.buffer.as_ptr().cast()) };
+ android_log(self.priority, self.tag, msg);
+
+ unsafe { *self.buffer.get_unchecked_mut(len) = last_byte };
+ }
+
+ /// Copy `len` bytes from `index` position to starting position.
+ fn copy_bytes_to_start(&mut self, index: usize, len: usize) {
+ let dst = self.buffer.as_mut_ptr();
+ let src = unsafe { self.buffer.as_ptr().add(index) };
+ unsafe { ptr::copy(src, dst, len) };
+ }
+}
+
+impl<'a> fmt::Write for PlatformLogWriter<'a> {
+ fn write_str(&mut self, s: &str) -> fmt::Result {
+ let mut incomming_bytes = s.as_bytes();
+
+ while !incomming_bytes.is_empty() {
+ let len = self.len;
+
+ // write everything possible to buffer and mark last \n
+ let new_len = len + incomming_bytes.len();
+ let last_newline = self.buffer[len..LOGGING_MSG_MAX_LEN]
+ .iter_mut()
+ .zip(incomming_bytes)
+ .enumerate()
+ .fold(None, |acc, (i, (output, input))| {
+ output.write(*input);
+ if *input == b'\n' {
+ Some(i)
+ } else {
+ acc
+ }
+ });
+
+ // update last \n index
+ if let Some(newline) = last_newline {
+ self.last_newline_index = len + newline;
+ }
+
+ // calculate how many bytes were written
+ let written_len = if new_len <= LOGGING_MSG_MAX_LEN {
+ // if the len was not exceeded
+ self.len = new_len;
+ new_len - len // written len
+ } else {
+ // if new length was exceeded
+ self.len = LOGGING_MSG_MAX_LEN;
+ self.temporal_flush();
+
+ LOGGING_MSG_MAX_LEN - len // written len
+ };
+
+ incomming_bytes = &incomming_bytes[written_len..];
+ }
+
+ Ok(())
+ }
+}
+
+/// Send a log record to Android logging backend.
+///
+/// This action does not require initialization. However, without initialization it
+/// will use the default filter, which allows all logs.
+pub fn log(record: &Record) {
+ ANDROID_LOGGER
+ .get_or_init(AndroidLogger::default)
+ .log(record)
+}
+
+/// Initializes the global logger with an android logger.
+///
+/// This can be called many times, but will only initialize logging once,
+/// and will not replace any other previously initialized logger.
+///
+/// It is ok to call this at the activity creation, and it will be
+/// repeatedly called on every lifecycle restart (i.e. screen rotation).
+pub fn init_once(config: Config) {
+ let log_level = config.log_level;
+ let logger = ANDROID_LOGGER.get_or_init(|| AndroidLogger::new(config));
+
+ if let Err(err) = log::set_logger(logger) {
+ debug!("android_logger: log::set_logger failed: {}", err);
+ } else if let Some(level) = log_level {
+ log::set_max_level(level);
+ }
+}
+
+// FIXME: When `maybe_uninit_uninit_array ` is stabilized, use it instead of this helper
+fn uninit_array<const N: usize, T>() -> [MaybeUninit<T>; N] {
+ // SAFETY: Array contains MaybeUninit, which is fine to be uninit
+ unsafe { MaybeUninit::uninit().assume_init() }
+}
+
+#[cfg(test)]
+mod tests {
+ use super::*;
+ use std::fmt::Write;
+ use std::sync::atomic::{AtomicBool, Ordering};
+
+ #[test]
+ fn check_config_values() {
+ // Filter is checked in config_filter_match below.
+ let config = Config::default()
+ .with_max_level(LevelFilter::Trace)
+ .with_tag("my_app");
+
+ assert_eq!(config.log_level, Some(LevelFilter::Trace));
+ assert_eq!(config.tag, Some(CString::new("my_app").unwrap()));
+ }
+
+ #[test]
+ fn log_calls_formatter() {
+ static FORMAT_FN_WAS_CALLED: AtomicBool = AtomicBool::new(false);
+ let config = Config::default()
+ .with_max_level(LevelFilter::Info)
+ .format(|_, _| {
+ FORMAT_FN_WAS_CALLED.store(true, Ordering::SeqCst);
+ Ok(())
+ });
+ let logger = AndroidLogger::new(config);
+
+ logger.log(&Record::builder().level(Level::Info).build());
+
+ assert!(FORMAT_FN_WAS_CALLED.load(Ordering::SeqCst));
+ }
+
+ #[test]
+ fn logger_enabled_threshold() {
+ let logger = AndroidLogger::new(Config::default().with_max_level(LevelFilter::Info));
+
+ assert!(logger.enabled(&log::MetadataBuilder::new().level(Level::Warn).build()));
+ assert!(logger.enabled(&log::MetadataBuilder::new().level(Level::Info).build()));
+ assert!(!logger.enabled(&log::MetadataBuilder::new().level(Level::Debug).build()));
+ }
+
+ // Test whether the filter gets called correctly. Not meant to be exhaustive for all filter
+ // options, as these are handled directly by the filter itself.
+ #[test]
+ fn config_filter_match() {
+ let info_record = Record::builder().level(Level::Info).build();
+ let debug_record = Record::builder().level(Level::Debug).build();
+
+ let info_all_filter = env_logger::filter::Builder::new().parse("info").build();
+ let info_all_config = Config::default().with_filter(info_all_filter);
+
+ assert!(info_all_config.filter_matches(&info_record));
+ assert!(!info_all_config.filter_matches(&debug_record));
+ }
+
+ #[test]
+ fn fill_tag_bytes_truncates_long_tag() {
+ let logger = AndroidLogger::new(Config::default());
+ let too_long_tag: [u8; LOGGING_TAG_MAX_LEN + 20] = [b'a'; LOGGING_TAG_MAX_LEN + 20];
+
+ let mut result: [MaybeUninit<u8>; LOGGING_TAG_MAX_LEN + 1] = uninit_array();
+ logger.fill_tag_bytes(&mut result, &too_long_tag);
+
+ let mut expected_result = [b'a'; LOGGING_TAG_MAX_LEN - 2].to_vec();
+ expected_result.extend("..\0".as_bytes());
+ assert_eq!(unsafe { assume_init_slice(&result) }, expected_result);
+ }
+
+ #[test]
+ fn fill_tag_bytes_keeps_short_tag() {
+ let logger = AndroidLogger::new(Config::default());
+ let short_tag: [u8; 3] = [b'a'; 3];
+
+ let mut result: [MaybeUninit<u8>; LOGGING_TAG_MAX_LEN + 1] = uninit_array();
+ logger.fill_tag_bytes(&mut result, &short_tag);
+
+ let mut expected_result = short_tag.to_vec();
+ expected_result.push(0);
+ assert_eq!(unsafe { assume_init_slice(&result[..4]) }, expected_result);
+ }
+
+ #[test]
+ fn platform_log_writer_init_values() {
+ let tag = CStr::from_bytes_with_nul(b"tag\0").unwrap();
+
+ let writer = PlatformLogWriter::new(Level::Warn, tag);
+
+ assert_eq!(writer.tag, tag);
+ // Android uses LogPriority instead, which doesn't implement equality checks
+ #[cfg(not(target_os = "android"))]
+ assert_eq!(writer.priority, Level::Warn);
+ }
+
+ #[test]
+ fn temporal_flush() {
+ let mut writer = get_tag_writer();
+
+ writer
+ .write_str("12\n\n567\n90")
+ .expect("Unable to write to PlatformLogWriter");
+
+ assert_eq!(writer.len, 10);
+ writer.temporal_flush();
+ // Should have flushed up until the last newline.
+ assert_eq!(writer.len, 3);
+ assert_eq!(writer.last_newline_index, 0);
+ assert_eq!(
+ unsafe { assume_init_slice(&writer.buffer[..writer.len]) },
+ "\n90".as_bytes()
+ );
+
+ writer.temporal_flush();
+ // Should have flushed all remaining bytes.
+ assert_eq!(writer.len, 0);
+ assert_eq!(writer.last_newline_index, 0);
+ }
+
+ #[test]
+ fn flush() {
+ let mut writer = get_tag_writer();
+ writer
+ .write_str("abcdefghij\n\nklm\nnopqr\nstuvwxyz")
+ .expect("Unable to write to PlatformLogWriter");
+
+ writer.flush();
+
+ assert_eq!(writer.last_newline_index, 0);
+ assert_eq!(writer.len, 0);
+ }
+
+ #[test]
+ fn last_newline_index() {
+ let mut writer = get_tag_writer();
+
+ writer
+ .write_str("12\n\n567\n90")
+ .expect("Unable to write to PlatformLogWriter");
+
+ assert_eq!(writer.last_newline_index, 7);
+ }
+
+ #[test]
+ fn output_specified_len_leaves_buffer_unchanged() {
+ let mut writer = get_tag_writer();
+ let log_string = "abcdefghij\n\nklm\nnopqr\nstuvwxyz";
+ writer
+ .write_str(log_string)
+ .expect("Unable to write to PlatformLogWriter");
+
+ writer.output_specified_len(5);
+
+ assert_eq!(
+ unsafe { assume_init_slice(&writer.buffer[..log_string.len()]) },
+ log_string.as_bytes()
+ );
+ }
+
+ #[test]
+ fn copy_bytes_to_start() {
+ let mut writer = get_tag_writer();
+ writer
+ .write_str("0123456789")
+ .expect("Unable to write to PlatformLogWriter");
+
+ writer.copy_bytes_to_start(3, 2);
+
+ assert_eq!(
+ unsafe { assume_init_slice(&writer.buffer[..10]) },
+ "3423456789".as_bytes()
+ );
+ }
+
+ #[test]
+ fn copy_bytes_to_start_nop() {
+ let test_string = "Test_string_with\n\n\n\nnewlines\n";
+ let mut writer = get_tag_writer();
+ writer
+ .write_str(test_string)
+ .expect("Unable to write to PlatformLogWriter");
+
+ writer.copy_bytes_to_start(0, 20);
+ writer.copy_bytes_to_start(10, 0);
+
+ assert_eq!(
+ unsafe { assume_init_slice(&writer.buffer[..test_string.len()]) },
+ test_string.as_bytes()
+ );
+ }
+
+ fn get_tag_writer() -> PlatformLogWriter<'static> {
+ PlatformLogWriter::new(Level::Warn, CStr::from_bytes_with_nul(b"tag\0").unwrap())
+ }
+
+ unsafe fn assume_init_slice<T>(slice: &[MaybeUninit<T>]) -> &[T] {
+ &*(slice as *const [MaybeUninit<T>] as *const [T])
+ }
+}
diff --git a/third_party/rust/android_logger/tests/config_log_level.rs b/third_party/rust/android_logger/tests/config_log_level.rs
new file mode 100644
index 0000000000..864b229f9c
--- /dev/null
+++ b/third_party/rust/android_logger/tests/config_log_level.rs
@@ -0,0 +1,11 @@
+extern crate android_logger;
+extern crate log;
+
+#[test]
+fn config_log_level() {
+ android_logger::init_once(
+ android_logger::Config::default().with_max_level(log::LevelFilter::Trace),
+ );
+
+ assert_eq!(log::max_level(), log::LevelFilter::Trace);
+}
diff --git a/third_party/rust/android_logger/tests/default_init.rs b/third_party/rust/android_logger/tests/default_init.rs
new file mode 100644
index 0000000000..7b04c24812
--- /dev/null
+++ b/third_party/rust/android_logger/tests/default_init.rs
@@ -0,0 +1,10 @@
+extern crate android_logger;
+extern crate log;
+
+#[test]
+fn default_init() {
+ android_logger::init_once(Default::default());
+
+ // android_logger has default log level "off"
+ assert_eq!(log::max_level(), log::LevelFilter::Off);
+}
diff --git a/third_party/rust/android_logger/tests/multiple_init.rs b/third_party/rust/android_logger/tests/multiple_init.rs
new file mode 100644
index 0000000000..26f815d521
--- /dev/null
+++ b/third_party/rust/android_logger/tests/multiple_init.rs
@@ -0,0 +1,16 @@
+extern crate android_logger;
+extern crate log;
+
+#[test]
+fn multiple_init() {
+ android_logger::init_once(
+ android_logger::Config::default().with_max_level(log::LevelFilter::Trace),
+ );
+
+ // Second initialization should be silently ignored
+ android_logger::init_once(
+ android_logger::Config::default().with_max_level(log::LevelFilter::Error),
+ );
+
+ assert_eq!(log::max_level(), log::LevelFilter::Trace);
+}