summaryrefslogtreecommitdiffstats
path: root/third_party/rust/enum-map-derive/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/enum-map-derive/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/enum-map-derive/Cargo.toml')
-rw-r--r--third_party/rust/enum-map-derive/Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/third_party/rust/enum-map-derive/Cargo.toml b/third_party/rust/enum-map-derive/Cargo.toml
new file mode 100644
index 0000000000..2e17e5d8ee
--- /dev/null
+++ b/third_party/rust/enum-map-derive/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.61"
+name = "enum-map-derive"
+version = "0.17.0"
+authors = ["Kamila Borowska <kamila@borowska.pw>"]
+description = "Macros 1.1 implementation of #[derive(Enum)]"
+readme = "README.md"
+keywords = [
+ "data-structure",
+ "no_std",
+ "enum",
+]
+categories = [
+ "data-structures",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://codeberg.org/xfix/enum-map"
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0.60"
+
+[dependencies.quote]
+version = "1.0.7"
+
+[dependencies.syn]
+version = "2.0.0"
+features = [
+ "derive",
+ "parsing",
+ "printing",
+ "proc-macro",
+]
+default-features = false
+
+[dev-dependencies]
+
+[badges.maintenance]
+status = "passively-maintained"