summaryrefslogtreecommitdiffstats
path: root/third_party/rust/threadbound
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/threadbound
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/threadbound')
-rw-r--r--third_party/rust/threadbound/.cargo-checksum.json1
-rw-r--r--third_party/rust/threadbound/Cargo.toml30
-rw-r--r--third_party/rust/threadbound/LICENSE-APACHE201
-rw-r--r--third_party/rust/threadbound/LICENSE-MIT23
-rw-r--r--third_party/rust/threadbound/README.md90
-rw-r--r--third_party/rust/threadbound/src/lib.rs143
6 files changed, 488 insertions, 0 deletions
diff --git a/third_party/rust/threadbound/.cargo-checksum.json b/third_party/rust/threadbound/.cargo-checksum.json
new file mode 100644
index 0000000000..7542f77024
--- /dev/null
+++ b/third_party/rust/threadbound/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"f1334f8d72c95094d33eebe78ddf6a7d6ee5f7aea949cc7d597cb33e6bc22b0a","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"e939611b59c971d4b8f2614552707ecd896dbcf3de3145224b0a97db6c3417fa","src/lib.rs":"8979dad6252c8fc615ae7f28fbd1f16416aa03507a76324b9470f2823d851a4d"},"package":"06638f039e6c49cd649d92e0e792f665d088bece8eba4c99c6fdfc2776b4ddb0"} \ No newline at end of file
diff --git a/third_party/rust/threadbound/Cargo.toml b/third_party/rust/threadbound/Cargo.toml
new file mode 100644
index 0000000000..b1a795a6f5
--- /dev/null
+++ b/third_party/rust/threadbound/Cargo.toml
@@ -0,0 +1,30 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.31"
+name = "threadbound"
+version = "0.1.5"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+description = "Make any value Sync but only available on its original thread."
+documentation = "https://docs.rs/threadbound"
+readme = "README.md"
+keywords = ["sync"]
+categories = [
+ "concurrency",
+ "rust-patterns",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/threadbound"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
diff --git a/third_party/rust/threadbound/LICENSE-APACHE b/third_party/rust/threadbound/LICENSE-APACHE
new file mode 100644
index 0000000000..16fe87b06e
--- /dev/null
+++ b/third_party/rust/threadbound/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/threadbound/LICENSE-MIT b/third_party/rust/threadbound/LICENSE-MIT
new file mode 100644
index 0000000000..31aa79387f
--- /dev/null
+++ b/third_party/rust/threadbound/LICENSE-MIT
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/third_party/rust/threadbound/README.md b/third_party/rust/threadbound/README.md
new file mode 100644
index 0000000000..9706401e9f
--- /dev/null
+++ b/third_party/rust/threadbound/README.md
@@ -0,0 +1,90 @@
+ThreadBound\<T\>
+================
+
+[<img alt="github" src="https://img.shields.io/badge/github-dtolnay/threadbound-8da0cb?style=for-the-badge&labelColor=555555&logo=github" height="20">](https://github.com/dtolnay/threadbound)
+[<img alt="crates.io" src="https://img.shields.io/crates/v/threadbound.svg?style=for-the-badge&color=fc8d62&logo=rust" height="20">](https://crates.io/crates/threadbound)
+[<img alt="docs.rs" src="https://img.shields.io/badge/docs.rs-threadbound-66c2a5?style=for-the-badge&labelColor=555555&logo=docs.rs" height="20">](https://docs.rs/threadbound)
+[<img alt="build status" src="https://img.shields.io/github/actions/workflow/status/dtolnay/threadbound/ci.yml?branch=master&style=for-the-badge" height="20">](https://github.com/dtolnay/threadbound/actions?query=branch%3Amaster)
+
+ThreadBound is a wrapper that binds a value to its original thread. The wrapper
+gets to be [`Sync`] and [`Send`] but only the original thread on which the
+ThreadBound was constructed can retrieve the underlying value.
+
+[`Sync`]: https://doc.rust-lang.org/std/marker/trait.Sync.html
+[`Send`]: https://doc.rust-lang.org/std/marker/trait.Send.html
+
+```toml
+[dependencies]
+threadbound = "0.1"
+```
+
+*Version requirement: rustc 1.31+*
+
+<br>
+
+### Example
+
+```rust
+extern crate threadbound;
+
+use std::marker::PhantomData;
+use std::rc::Rc;
+use std::sync::Arc;
+use threadbound::ThreadBound;
+
+// Neither Send nor Sync. Maybe the index points into a
+// thread-local interner.
+#[derive(Copy, Clone)]
+struct Span {
+ index: u32,
+ marker: PhantomData<Rc<()>>,
+}
+
+// Error types are always supposed to be Send and Sync.
+// We can use ThreadBound to make it so.
+struct Error {
+ span: ThreadBound<Span>,
+ message: String,
+}
+
+fn main() {
+ let err = Error {
+ span: ThreadBound::new(Span {
+ index: 99,
+ marker: PhantomData,
+ }),
+ message: "fearless concurrency".to_owned(),
+ };
+
+ // Original thread can see the contents.
+ assert_eq!(err.span.get_ref().unwrap().index, 99);
+
+ let err = Arc::new(err);
+ let err2 = err.clone();
+ std::thread::spawn(move || {
+ // Other threads cannot get access. Maybe they use
+ // a default value or a different codepath.
+ assert!(err2.span.get_ref().is_none());
+ });
+
+ // Original thread can still see the contents.
+ assert_eq!(err.span.get_ref().unwrap().index, 99);
+}
+```
+
+<br>
+
+#### License
+
+<sup>
+Licensed under either of <a href="LICENSE-APACHE">Apache License, Version
+2.0</a> or <a href="LICENSE-MIT">MIT license</a> at your option.
+</sup>
+
+<br>
+
+<sub>
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in this crate by you, as defined in the Apache-2.0 license, shall
+be dual licensed as above, without any additional terms or conditions.
+</sub>
diff --git a/third_party/rust/threadbound/src/lib.rs b/third_party/rust/threadbound/src/lib.rs
new file mode 100644
index 0000000000..45a84f896f
--- /dev/null
+++ b/third_party/rust/threadbound/src/lib.rs
@@ -0,0 +1,143 @@
+//! [![github]](https://github.com/dtolnay/threadbound)&ensp;[![crates-io]](https://crates.io/crates/threadbound)&ensp;[![docs-rs]](https://docs.rs/threadbound)
+//!
+//! [github]: https://img.shields.io/badge/github-8da0cb?style=for-the-badge&labelColor=555555&logo=github
+//! [crates-io]: https://img.shields.io/badge/crates.io-fc8d62?style=for-the-badge&labelColor=555555&logo=rust
+//! [docs-rs]: https://img.shields.io/badge/docs.rs-66c2a5?style=for-the-badge&labelColor=555555&logo=docs.rs
+//!
+//! <br>
+//!
+//! [`ThreadBound<T>`] is a wrapper that binds a value to its original thread.
+//! The wrapper gets to be [`Sync`] and [`Send`] but only the original thread on
+//! which the ThreadBound was constructed can retrieve the underlying value.
+//!
+//! [`ThreadBound<T>`]: struct.ThreadBound.html
+//! [`Sync`]: https://doc.rust-lang.org/std/marker/trait.Sync.html
+//! [`Send`]: https://doc.rust-lang.org/std/marker/trait.Send.html
+//!
+//! # Example
+//!
+//! ```
+//! use std::marker::PhantomData;
+//! use std::rc::Rc;
+//! use std::sync::Arc;
+//! use threadbound::ThreadBound;
+//!
+//! // Neither Send nor Sync. Maybe the index points into a
+//! // thread-local interner.
+//! #[derive(Copy, Clone)]
+//! struct Span {
+//! index: u32,
+//! marker: PhantomData<Rc<()>>,
+//! }
+//!
+//! // Error types are always supposed to be Send and Sync.
+//! // We can use ThreadBound to make it so.
+//! struct Error {
+//! span: ThreadBound<Span>,
+//! message: String,
+//! }
+//!
+//! fn main() {
+//! let err = Error {
+//! span: ThreadBound::new(Span {
+//! index: 99,
+//! marker: PhantomData,
+//! }),
+//! message: "fearless concurrency".to_owned(),
+//! };
+//!
+//! // Original thread can see the contents.
+//! assert_eq!(err.span.get_ref().unwrap().index, 99);
+//!
+//! let err = Arc::new(err);
+//! let err2 = err.clone();
+//! std::thread::spawn(move || {
+//! // Other threads cannot get access. Maybe they use
+//! // a default value or a different codepath.
+//! assert!(err2.span.get_ref().is_none());
+//! });
+//!
+//! // Original thread can still see the contents.
+//! assert_eq!(err.span.get_ref().unwrap().index, 99);
+//! }
+//! ```
+
+#![doc(html_root_url = "https://docs.rs/threadbound/0.1.5")]
+#![allow(clippy::doc_markdown)]
+
+use std::fmt::{self, Debug};
+use std::thread::{self, ThreadId};
+
+/// ThreadBound is a Sync-maker and Send-maker that allows accessing a value
+/// of type T only from the original thread on which the ThreadBound was
+/// constructed.
+///
+/// Refer to the [crate-level documentation] for a usage example.
+///
+/// [crate-level documentation]: index.html
+pub struct ThreadBound<T> {
+ value: T,
+ thread_id: ThreadId,
+}
+
+unsafe impl<T> Sync for ThreadBound<T> {}
+
+// Send bound requires Copy, as otherwise Drop could run in the wrong place.
+unsafe impl<T: Copy> Send for ThreadBound<T> {}
+
+impl<T> ThreadBound<T> {
+ /// Binds a value to the current thread. The wrapper can be sent around to
+ /// other threads, but no other threads will be able to access the
+ /// underlying value.
+ pub fn new(value: T) -> Self {
+ ThreadBound {
+ value,
+ thread_id: thread::current().id(),
+ }
+ }
+
+ /// Accesses a reference to the underlying value if this is its original
+ /// thread, otherwise `None`.
+ pub fn get_ref(&self) -> Option<&T> {
+ if thread::current().id() == self.thread_id {
+ Some(&self.value)
+ } else {
+ None
+ }
+ }
+
+ /// Accesses a mutable reference to the underlying value if this is its
+ /// original thread, otherwise `None`.
+ pub fn get_mut(&mut self) -> Option<&mut T> {
+ if thread::current().id() == self.thread_id {
+ Some(&mut self.value)
+ } else {
+ None
+ }
+ }
+
+ /// Extracts ownership of the underlying value if this is its original
+ /// thread, otherwise `None`.
+ pub fn into_inner(self) -> Option<T> {
+ if thread::current().id() == self.thread_id {
+ Some(self.value)
+ } else {
+ None
+ }
+ }
+}
+
+impl<T: Default> Default for ThreadBound<T> {
+ fn default() -> Self {
+ ThreadBound::new(Default::default())
+ }
+}
+
+impl<T: Debug> Debug for ThreadBound<T> {
+ fn fmt(&self, formatter: &mut fmt::Formatter) -> fmt::Result {
+ match self.get_ref() {
+ Some(value) => Debug::fmt(value, formatter),
+ None => formatter.write_str("unknown"),
+ }
+ }
+}