summaryrefslogtreecommitdiffstats
path: root/build/rust/indexmap
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust/indexmap')
-rw-r--r--build/rust/indexmap/Cargo.toml16
-rw-r--r--build/rust/indexmap/lib.rs5
2 files changed, 21 insertions, 0 deletions
diff --git a/build/rust/indexmap/Cargo.toml b/build/rust/indexmap/Cargo.toml
new file mode 100644
index 0000000000..de45a4f02d
--- /dev/null
+++ b/build/rust/indexmap/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "indexmap"
+version = "2.999.999"
+edition = "2021"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[features]
+default = ["std"]
+serde = ["indexmap/serde-1"]
+std = ["indexmap/std"]
+
+[dependencies.indexmap]
+version = "1.9.3"
diff --git a/build/rust/indexmap/lib.rs b/build/rust/indexmap/lib.rs
new file mode 100644
index 0000000000..8142a8bd1d
--- /dev/null
+++ b/build/rust/indexmap/lib.rs
@@ -0,0 +1,5 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use indexmap::*;