summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 11:32:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 11:32:39 +0000
commit56ae875861ab260b80a030f50c4aff9f9dc8fff0 (patch)
tree531412110fc901a5918c7f7442202804a83cada9 /doc/CMakeLists.txt
parentInitial commit. (diff)
downloadicinga2-upstream.tar.xz
icinga2-upstream.zip
Adding upstream version 2.14.2.upstream/2.14.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 0000000..3be5b58
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Icinga 2 | (c) 2012 Icinga GmbH | GPLv2+
+
+file(GLOB DOCSRCS "*.md")
+
+if(UNIX OR CYGWIN)
+ install(
+ FILES icinga2.8
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man8
+ )
+endif()
+
+install(
+ FILES ${DOCSRCS}
+ DESTINATION ${CMAKE_INSTALL_DOCDIR}/markdown
+)
+
+install(
+ DIRECTORY images
+ DESTINATION ${CMAKE_INSTALL_DOCDIR}/markdown
+)