summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 0000000..3be5b58
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Icinga 2 | (c) 2012 Icinga GmbH | GPLv2+
+
+file(GLOB DOCSRCS "*.md")
+
+if(UNIX OR CYGWIN)
+ install(
+ FILES icinga2.8
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man8
+ )
+endif()
+
+install(
+ FILES ${DOCSRCS}
+ DESTINATION ${CMAKE_INSTALL_DOCDIR}/markdown
+)
+
+install(
+ DIRECTORY images
+ DESTINATION ${CMAKE_INSTALL_DOCDIR}/markdown
+)