summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules36
1 files changed, 18 insertions, 18 deletions
diff --git a/debian/rules b/debian/rules
index cdb3a7f..5bf8ad7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,7 @@ export DPKG_GENSYMBOLS_CHECK_LEVEL := 4
export KNOT_SOFTHSM2_DSO = /usr/lib/softhsm/libsofthsm2.so
export KNOT_VERSION_FORMAT = release
-ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),riscv64))
+ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),armel))
export DEB_LDFLAGS_MAINT_APPEND += -latomic
endif
@@ -19,26 +19,26 @@ else
FASTPARSER := --enable-fastparser
endif
-# To make it build on sh4.
-# See https://buildd.debian.org/status/fetch.php?pkg=knot&arch=sh4&ver=3.0.2-2&stamp=1607372581&raw=0
-ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),sh4))
- FASTPARSER := --disable-fastparser
-else
- FASTPARSER := --enable-fastparser
-endif
-
-ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),hurd-i386))
- RECVMMSG:=--enable-recvmmsg=no
-else
- RECVMMSG:=--enable-recvmmsg=yes
-endif
-
ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),amd64 i386))
RUN_TEST :=
else
RUN_TEST := -timeout --kill-after=5s 5m
endif
+ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),hurd-amd64 hurd-i386 sh4))
+ FASTPARSER := --disable-fastparser
+ RECVMMSG := --enable-recvmmsg=no
+ RRL := --with-module-rrl=no
+ GEOIP := --with-modle-geoip=no
+ DNSTAP := --disable-dnstap --with-module-dnstap=no
+else
+ FASTPARSER := --enable-fastparser
+ RECVMMSG := --enable-recvmmsg=yes
+ RRL := --with-module-rrl=yes
+ GEOIP := --with-module-geoip=shared
+ DNSTAP := --enable-dnstap --with-module-dnstap=shared
+endif
+
# MAJOR.MINOR version part
BASE_VERSION := $(shell echo $(DEB_VERSION) | sed 's/^\([^.]\+\.[^.]\+\).*/\1/')
@@ -66,9 +66,9 @@ override_dh_auto_configure:
--with-moduledir=/usr/lib/$(DEB_HOST_MULTIARCH)/knot/modules-$(BASE_VERSION) \
--with-storage=/var/lib/knot \
--enable-systemd=auto \
- --enable-dnstap \
- --with-module-dnstap=shared \
- --with-module-geoip=shared \
+ $(RRL) \
+ $(GEOIP) \
+ $(DNSTAP) \
$(RECVMMSG) \
$(FASTPARSER) \
--disable-silent-rules \