summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog14
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules36
3 files changed, 34 insertions, 20 deletions
diff --git a/debian/changelog b/debian/changelog
index 8cbc5a1..999cec2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+knot (3.4.0-2) unstable; urgency=medium
+
+ [ Jakub Ružička ]
+ * Drop t64 suffix from libknot15 after soname bump (Closes: #1080499)
+
+ [ Daniel Salzman ]
+ * Update -latomic usage (Closes: #1080514)
+ * Disable DNSTAP on hurd-amd64 and hurd-i386
+ * Disable GEOIP on hurd-amd64 and hurd-i386
+ * Unification of architecture-dependent exceptions
+ * Disable RRL on hurd-amd64 and hurd-i386
+
+ -- Jakub Ružička <jru@debian.org> Thu, 05 Sep 2024 15:15:17 +0200
+
knot (3.4.0-1~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/control b/debian/control
index 0a0d76b..96d6c8e 100644
--- a/debian/control
+++ b/debian/control
@@ -20,11 +20,11 @@ Build-Depends:
libbpf-dev [!hurd-amd64 !hurd-i386 !alpha !arc !hppa !ia64 !loong64 !m68k !powerpc !sh4 !sparc64 !x32],
libcap-ng-dev [!hurd-amd64 !hurd-i386],
libedit-dev,
- libfstrm-dev,
+ libfstrm-dev [!hurd-amd64 !hurd-i386],
libgnutls28-dev,
libidn2-dev,
liblmdb-dev,
- libmaxminddb-dev,
+ libmaxminddb-dev [!hurd-amd64 !hurd-i386],
libmnl-dev [!hurd-amd64 !hurd-i386 !alpha !arc !hppa !ia64 !loong64 !m68k !powerpc !sh4 !sparc64 !x32],
libnghttp2-dev,
libngtcp2-crypto-gnutls-dev [!hurd-amd64 !hurd-i386 !alpha !arc !hppa !ia64 !loong64 !m68k !powerpc !sh4 !sparc64 !x32],
diff --git a/debian/rules b/debian/rules
index cdb3a7f..5bf8ad7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,7 @@ export DPKG_GENSYMBOLS_CHECK_LEVEL := 4
export KNOT_SOFTHSM2_DSO = /usr/lib/softhsm/libsofthsm2.so
export KNOT_VERSION_FORMAT = release
-ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),riscv64))
+ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),armel))
export DEB_LDFLAGS_MAINT_APPEND += -latomic
endif
@@ -19,26 +19,26 @@ else
FASTPARSER := --enable-fastparser
endif
-# To make it build on sh4.
-# See https://buildd.debian.org/status/fetch.php?pkg=knot&arch=sh4&ver=3.0.2-2&stamp=1607372581&raw=0
-ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),sh4))
- FASTPARSER := --disable-fastparser
-else
- FASTPARSER := --enable-fastparser
-endif
-
-ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),hurd-i386))
- RECVMMSG:=--enable-recvmmsg=no
-else
- RECVMMSG:=--enable-recvmmsg=yes
-endif
-
ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),amd64 i386))
RUN_TEST :=
else
RUN_TEST := -timeout --kill-after=5s 5m
endif
+ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),hurd-amd64 hurd-i386 sh4))
+ FASTPARSER := --disable-fastparser
+ RECVMMSG := --enable-recvmmsg=no
+ RRL := --with-module-rrl=no
+ GEOIP := --with-modle-geoip=no
+ DNSTAP := --disable-dnstap --with-module-dnstap=no
+else
+ FASTPARSER := --enable-fastparser
+ RECVMMSG := --enable-recvmmsg=yes
+ RRL := --with-module-rrl=yes
+ GEOIP := --with-module-geoip=shared
+ DNSTAP := --enable-dnstap --with-module-dnstap=shared
+endif
+
# MAJOR.MINOR version part
BASE_VERSION := $(shell echo $(DEB_VERSION) | sed 's/^\([^.]\+\.[^.]\+\).*/\1/')
@@ -66,9 +66,9 @@ override_dh_auto_configure:
--with-moduledir=/usr/lib/$(DEB_HOST_MULTIARCH)/knot/modules-$(BASE_VERSION) \
--with-storage=/var/lib/knot \
--enable-systemd=auto \
- --enable-dnstap \
- --with-module-dnstap=shared \
- --with-module-geoip=shared \
+ $(RRL) \
+ $(GEOIP) \
+ $(DNSTAP) \
$(RECVMMSG) \
$(FASTPARSER) \
--disable-silent-rules \