summaryrefslogtreecommitdiffstats
path: root/benchmark/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:48:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:48:59 +0000
commitc484829272cd13a738e35412498e12f2c9a194ac (patch)
treea1f5ec09629ee895bd3963fa8820b45f2f4c574b /benchmark/Makefile.am
parentInitial commit. (diff)
downloadliborcus-upstream.tar.xz
liborcus-upstream.zip
Adding upstream version 0.19.2.upstream/0.19.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'benchmark/Makefile.am')
-rw-r--r--benchmark/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/benchmark/Makefile.am b/benchmark/Makefile.am
new file mode 100644
index 0000000..a2f81eb
--- /dev/null
+++ b/benchmark/Makefile.am
@@ -0,0 +1,30 @@
+
+AM_CPPFLAGS = -I$(top_srcdir)/include
+
+EXTRA_PROGRAMS = \
+ json-parser-test \
+ threaded-json-parser-test
+
+json_parser_test_SOURCES = \
+ json_parser.cpp
+
+json_parser_test_LDADD = \
+ ../src/parser/liborcus-parser-@ORCUS_API_VERSION@.la
+
+json_parser_test_CPPFLAGS = $(AM_CPPFLAGS)
+
+
+threaded_json_parser_test_SOURCES = \
+ threaded_json_parser.cpp
+
+threaded_json_parser_test_LDADD = \
+ ../src/parser/liborcus-parser-@ORCUS_API_VERSION@.la
+
+threaded_json_parser_test_CPPFLAGS = $(AM_CPPFLAGS)
+
+CLEANFILES = $(EXTRA_PROGRAMS)
+
+.PHONY: all
+
+all: $(EXTRA_PROGRAMS)
+