summaryrefslogtreecommitdiffstats
path: root/benchmark/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'benchmark/Makefile.am')
-rw-r--r--benchmark/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/benchmark/Makefile.am b/benchmark/Makefile.am
new file mode 100644
index 0000000..a2f81eb
--- /dev/null
+++ b/benchmark/Makefile.am
@@ -0,0 +1,30 @@
+
+AM_CPPFLAGS = -I$(top_srcdir)/include
+
+EXTRA_PROGRAMS = \
+ json-parser-test \
+ threaded-json-parser-test
+
+json_parser_test_SOURCES = \
+ json_parser.cpp
+
+json_parser_test_LDADD = \
+ ../src/parser/liborcus-parser-@ORCUS_API_VERSION@.la
+
+json_parser_test_CPPFLAGS = $(AM_CPPFLAGS)
+
+
+threaded_json_parser_test_SOURCES = \
+ threaded_json_parser.cpp
+
+threaded_json_parser_test_LDADD = \
+ ../src/parser/liborcus-parser-@ORCUS_API_VERSION@.la
+
+threaded_json_parser_test_CPPFLAGS = $(AM_CPPFLAGS)
+
+CLEANFILES = $(EXTRA_PROGRAMS)
+
+.PHONY: all
+
+all: $(EXTRA_PROGRAMS)
+