summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec
parentInitial commit. (diff)
downloadlintian-upstream.tar.xz
lintian-upstream.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/debian/changelog/changelog-file-symlink/build-spec')
-rwxr-xr-xt/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/debian/rules12
-rw-r--r--t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/fill-values3
2 files changed, 15 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/debian/rules b/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/debian/rules
new file mode 100755
index 0000000..fa478f6
--- /dev/null
+++ b/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+
+override_dh_md5sums:
+ DIR=$$(find debian/*/ -type f -a -name 'changelog.gz' \
+ -exec dirname {} \; ) ; \
+ rm -f $$DIR/changelog.gz ; \
+ ln -s ../lintian/changelog.gz $$DIR/changelog.gz
+ dh_md5sums
diff --git a/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/fill-values b/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/fill-values
new file mode 100644
index 0000000..3d57c66
--- /dev/null
+++ b/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: changelog-file-symlink
+Description: Test if Debian changelog is a symlink