summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/changelog/changelog-file-symlink/build-spec')
-rwxr-xr-xt/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/debian/rules12
-rw-r--r--t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/fill-values3
2 files changed, 15 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/debian/rules b/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/debian/rules
new file mode 100755
index 0000000..fa478f6
--- /dev/null
+++ b/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+
+override_dh_md5sums:
+ DIR=$$(find debian/*/ -type f -a -name 'changelog.gz' \
+ -exec dirname {} \; ) ; \
+ rm -f $$DIR/changelog.gz ; \
+ ln -s ../lintian/changelog.gz $$DIR/changelog.gz
+ dh_md5sums
diff --git a/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/fill-values b/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/fill-values
new file mode 100644
index 0000000..3d57c66
--- /dev/null
+++ b/t/recipes/checks/debian/changelog/changelog-file-symlink/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: changelog-file-symlink
+Description: Test if Debian changelog is a symlink