summaryrefslogtreecommitdiffstats
path: root/fs/9p/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
commitace9429bb58fd418f0c81d4c2835699bddf6bde6 (patch)
treeb2d64bc10158fdd5497876388cd68142ca374ed3 /fs/9p/Makefile
parentInitial commit. (diff)
downloadlinux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.tar.xz
linux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.zip
Adding upstream version 6.6.15.upstream/6.6.15
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fs/9p/Makefile')
-rw-r--r--fs/9p/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/fs/9p/Makefile b/fs/9p/Makefile
new file mode 100644
index 000000000..e7800a5c7
--- /dev/null
+++ b/fs/9p/Makefile
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_9P_FS) := 9p.o
+
+9p-objs := \
+ vfs_super.o \
+ vfs_inode.o \
+ vfs_inode_dotl.o \
+ vfs_addr.o \
+ vfs_file.o \
+ vfs_dir.o \
+ vfs_dentry.o \
+ v9fs.o \
+ fid.o \
+ xattr.o
+
+9p-$(CONFIG_9P_FSCACHE) += cache.o
+9p-$(CONFIG_9P_FS_POSIX_ACL) += acl.o