summaryrefslogtreecommitdiffstats
path: root/fs/9p/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/9p/Makefile')
-rw-r--r--fs/9p/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/fs/9p/Makefile b/fs/9p/Makefile
new file mode 100644
index 000000000..e7800a5c7
--- /dev/null
+++ b/fs/9p/Makefile
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_9P_FS) := 9p.o
+
+9p-objs := \
+ vfs_super.o \
+ vfs_inode.o \
+ vfs_inode_dotl.o \
+ vfs_addr.o \
+ vfs_file.o \
+ vfs_dir.o \
+ vfs_dentry.o \
+ v9fs.o \
+ fid.o \
+ xattr.o
+
+9p-$(CONFIG_9P_FSCACHE) += cache.o
+9p-$(CONFIG_9P_FS_POSIX_ACL) += acl.o