summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian/0001-meson-nose2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian/0001-meson-nose2.patch')
-rw-r--r--debian/patches/debian/0001-meson-nose2.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/patches/debian/0001-meson-nose2.patch b/debian/patches/debian/0001-meson-nose2.patch
new file mode 100644
index 0000000..37b5717
--- /dev/null
+++ b/debian/patches/debian/0001-meson-nose2.patch
@@ -0,0 +1,15 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Updating meson to find /usr/bin/nose2-3 (python3).
+
+diff -Naurp nvme-cli.orig/tests/meson.build nvme-cli/tests/meson.build
+--- nvme-cli.orig/tests/meson.build
++++ nvme-cli/tests/meson.build
+@@ -31,7 +31,7 @@ tests = [
+ 'nvme_ctrl_reset_test.py',
+ ]
+
+-runtests = find_program('nose2', required : false)
++runtests = find_program('nose2-3', required : false)
+
+ if meson.version().version_compare('>= 0.56')
+ nvmecli_path = meson.project_build_root()