summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian/0001-meson-nose2.patch15
-rw-r--r--debian/patches/debian/0002-meson-systemd.patch15
-rw-r--r--debian/patches/series2
3 files changed, 32 insertions, 0 deletions
diff --git a/debian/patches/debian/0001-meson-nose2.patch b/debian/patches/debian/0001-meson-nose2.patch
new file mode 100644
index 0000000..37b5717
--- /dev/null
+++ b/debian/patches/debian/0001-meson-nose2.patch
@@ -0,0 +1,15 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Updating meson to find /usr/bin/nose2-3 (python3).
+
+diff -Naurp nvme-cli.orig/tests/meson.build nvme-cli/tests/meson.build
+--- nvme-cli.orig/tests/meson.build
++++ nvme-cli/tests/meson.build
+@@ -31,7 +31,7 @@ tests = [
+ 'nvme_ctrl_reset_test.py',
+ ]
+
+-runtests = find_program('nose2', required : false)
++runtests = find_program('nose2-3', required : false)
+
+ if meson.version().version_compare('>= 0.56')
+ nvmecli_path = meson.project_build_root()
diff --git a/debian/patches/debian/0002-meson-systemd.patch b/debian/patches/debian/0002-meson-systemd.patch
new file mode 100644
index 0000000..732544b
--- /dev/null
+++ b/debian/patches/debian/0002-meson-systemd.patch
@@ -0,0 +1,15 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Overwriting systemd unit directory until debhelper supports /usr/lib/systemd/system (Closes: #1034232).
+
+diff -Naurp nvme-cli.orig/meson.build nvme-cli/meson.build
+--- nvme-cli.orig/meson.build
++++ nvme-cli/meson.build
+@@ -26,7 +26,7 @@ sysconfdir = join_paths(prefixdir, get_option('sysconfdir'))
+
+ udevrulesdir = join_paths(prefixdir, get_option('udevrulesdir'))
+ dracutrulesdir = join_paths(prefixdir, get_option('dracutrulesdir'))
+-systemddir = join_paths(prefixdir, get_option('systemddir'))
++systemddir = '/lib/systemd/system'
+ rundir = join_paths(prefixdir, get_option('rundir'))
+
+ ###############################################################################
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..4758381
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+debian/0001-meson-nose2.patch
+debian/0002-meson-systemd.patch