summaryrefslogtreecommitdiffstats
path: root/src/bootstrap/mk/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /src/bootstrap/mk/Makefile.in
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/bootstrap/mk/Makefile.in')
-rw-r--r--src/bootstrap/mk/Makefile.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/bootstrap/mk/Makefile.in b/src/bootstrap/mk/Makefile.in
index a9865e262..0b6707991 100644
--- a/src/bootstrap/mk/Makefile.in
+++ b/src/bootstrap/mk/Makefile.in
@@ -6,6 +6,13 @@ Q := @
BOOTSTRAP_ARGS :=
endif
+# Pass `-jN` to the bootstrap if it is specified.
+ifdef MAKEFLAGS
+ ifneq (,$(findstring -j, $(MAKEFLAGS)))
+ BOOTSTRAP_ARGS += $(filter -j%, $(MAKEFLAGS))
+ endif
+endif
+
BOOTSTRAP := $(CFG_PYTHON) $(CFG_SRC_DIR)src/bootstrap/bootstrap.py
all: