summaryrefslogtreecommitdiffstats
path: root/src/bootstrap/mk/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/bootstrap/mk/Makefile.in')
-rw-r--r--src/bootstrap/mk/Makefile.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/bootstrap/mk/Makefile.in b/src/bootstrap/mk/Makefile.in
index a9865e262..0b6707991 100644
--- a/src/bootstrap/mk/Makefile.in
+++ b/src/bootstrap/mk/Makefile.in
@@ -6,6 +6,13 @@ Q := @
BOOTSTRAP_ARGS :=
endif
+# Pass `-jN` to the bootstrap if it is specified.
+ifdef MAKEFLAGS
+ ifneq (,$(findstring -j, $(MAKEFLAGS)))
+ BOOTSTRAP_ARGS += $(filter -j%, $(MAKEFLAGS))
+ endif
+endif
+
BOOTSTRAP := $(CFG_PYTHON) $(CFG_SRC_DIR)src/bootstrap/bootstrap.py
all: