summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/allow-warnings-cmdline-stability
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make-fulldeps/allow-warnings-cmdline-stability
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/allow-warnings-cmdline-stability')
-rw-r--r--src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile15
-rw-r--r--src/test/run-make-fulldeps/allow-warnings-cmdline-stability/bar.rs5
-rw-r--r--src/test/run-make-fulldeps/allow-warnings-cmdline-stability/foo.rs5
3 files changed, 0 insertions, 25 deletions
diff --git a/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile b/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile
deleted file mode 100644
index 1ce8d0ec2..000000000
--- a/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-include ../tools.mk
-
-# Test that -A warnings makes the 'empty trait list for derive' warning go away
-DEP=$(shell $(RUSTC) bar.rs)
-OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
-
-all: foo bar
- test -z '$(OUT)'
-
-# These are just to ensure that the above commands actually work
-bar:
- $(RUSTC) bar.rs
-
-foo: bar
- $(RUSTC) foo.rs -A warnings
diff --git a/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/bar.rs b/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/bar.rs
deleted file mode 100644
index 3dcfb9dad..000000000
--- a/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/bar.rs
+++ /dev/null
@@ -1,5 +0,0 @@
-#![crate_type = "lib"]
-#![feature(staged_api)]
-#![unstable(feature = "unstable_test_feature", issue = "none")]
-
-pub fn baz() {}
diff --git a/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/foo.rs b/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/foo.rs
deleted file mode 100644
index 869b54354..000000000
--- a/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/foo.rs
+++ /dev/null
@@ -1,5 +0,0 @@
-#![feature(unstable_test_feature)]
-
-extern crate bar;
-
-pub fn main() { bar::baz() }