summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/link-cfg/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make-fulldeps/link-cfg/Makefile
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/link-cfg/Makefile')
-rw-r--r--src/test/run-make-fulldeps/link-cfg/Makefile22
1 files changed, 0 insertions, 22 deletions
diff --git a/src/test/run-make-fulldeps/link-cfg/Makefile b/src/test/run-make-fulldeps/link-cfg/Makefile
deleted file mode 100644
index 0b25ccded..000000000
--- a/src/test/run-make-fulldeps/link-cfg/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-include ../tools.mk
-
-all: $(call DYLIB,return1) $(call DYLIB,return2) $(call NATIVE_STATICLIB,return3)
- ls $(TMPDIR)
- $(BARE_RUSTC) --print cfg --target x86_64-unknown-linux-musl | $(CGREP) crt-static
-
- $(RUSTC) no-deps.rs --cfg foo
- $(call RUN,no-deps)
- $(RUSTC) no-deps.rs --cfg bar
- $(call RUN,no-deps)
-
- $(RUSTC) dep.rs
- $(RUSTC) with-deps.rs --cfg foo
- $(call RUN,with-deps)
- $(RUSTC) with-deps.rs --cfg bar
- $(call RUN,with-deps)
-
- $(RUSTC) dep-with-staticlib.rs
- $(RUSTC) with-staticlib-deps.rs --cfg foo
- $(call RUN,with-staticlib-deps)
- $(RUSTC) with-staticlib-deps.rs --cfg bar
- $(call RUN,with-staticlib-deps)