summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/link-cfg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/link-cfg/Makefile')
-rw-r--r--src/test/run-make-fulldeps/link-cfg/Makefile22
1 files changed, 0 insertions, 22 deletions
diff --git a/src/test/run-make-fulldeps/link-cfg/Makefile b/src/test/run-make-fulldeps/link-cfg/Makefile
deleted file mode 100644
index 0b25ccded..000000000
--- a/src/test/run-make-fulldeps/link-cfg/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-include ../tools.mk
-
-all: $(call DYLIB,return1) $(call DYLIB,return2) $(call NATIVE_STATICLIB,return3)
- ls $(TMPDIR)
- $(BARE_RUSTC) --print cfg --target x86_64-unknown-linux-musl | $(CGREP) crt-static
-
- $(RUSTC) no-deps.rs --cfg foo
- $(call RUN,no-deps)
- $(RUSTC) no-deps.rs --cfg bar
- $(call RUN,no-deps)
-
- $(RUSTC) dep.rs
- $(RUSTC) with-deps.rs --cfg foo
- $(call RUN,with-deps)
- $(RUSTC) with-deps.rs --cfg bar
- $(call RUN,with-deps)
-
- $(RUSTC) dep-with-staticlib.rs
- $(RUSTC) with-staticlib-deps.rs --cfg foo
- $(call RUN,with-staticlib-deps)
- $(RUSTC) with-staticlib-deps.rs --cfg bar
- $(call RUN,with-staticlib-deps)