summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/tests/testsuite/inheritable_workspace_fields.rs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /src/tools/cargo/tests/testsuite/inheritable_workspace_fields.rs
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/tools/cargo/tests/testsuite/inheritable_workspace_fields.rs')
-rw-r--r--src/tools/cargo/tests/testsuite/inheritable_workspace_fields.rs8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/tools/cargo/tests/testsuite/inheritable_workspace_fields.rs b/src/tools/cargo/tests/testsuite/inheritable_workspace_fields.rs
index cc261a47f..47437102a 100644
--- a/src/tools/cargo/tests/testsuite/inheritable_workspace_fields.rs
+++ b/src/tools/cargo/tests/testsuite/inheritable_workspace_fields.rs
@@ -1234,8 +1234,11 @@ fn error_workspace_false() {
[ERROR] failed to parse manifest at `[CWD]/Cargo.toml`
Caused by:
+ TOML parse error at line 7, column 41
+ |
+ 7 | description = { workspace = false }
+ | ^^^^^
`workspace` cannot be false
- in `package.description.workspace`
",
)
.run();
@@ -1323,9 +1326,6 @@ fn error_malformed_workspace_root() {
Caused by:
[..]
-
-Caused by:
- [..]
|
3 | members = [invalid toml
| ^