summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/c-link-to-rust-staticlib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/c-link-to-rust-staticlib
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/c-link-to-rust-staticlib')
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-staticlib/Makefile12
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-staticlib/bar.c6
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-staticlib/foo.rs4
3 files changed, 0 insertions, 22 deletions
diff --git a/tests/run-make-fulldeps/c-link-to-rust-staticlib/Makefile b/tests/run-make-fulldeps/c-link-to-rust-staticlib/Makefile
deleted file mode 100644
index d38bcef30..000000000
--- a/tests/run-make-fulldeps/c-link-to-rust-staticlib/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-include ../tools.mk
-
-# ignore-freebsd
-# FIXME
-
-all:
- $(RUSTC) foo.rs
- $(CC) bar.c $(call STATICLIB,foo) $(call OUT_EXE,bar) \
- $(EXTRACFLAGS) $(EXTRACXXFLAGS)
- $(call RUN,bar)
- rm $(call STATICLIB,foo)
- $(call RUN,bar)
diff --git a/tests/run-make-fulldeps/c-link-to-rust-staticlib/bar.c b/tests/run-make-fulldeps/c-link-to-rust-staticlib/bar.c
deleted file mode 100644
index bb4036b06..000000000
--- a/tests/run-make-fulldeps/c-link-to-rust-staticlib/bar.c
+++ /dev/null
@@ -1,6 +0,0 @@
-void foo();
-
-int main() {
- foo();
- return 0;
-}
diff --git a/tests/run-make-fulldeps/c-link-to-rust-staticlib/foo.rs b/tests/run-make-fulldeps/c-link-to-rust-staticlib/foo.rs
deleted file mode 100644
index 2e59432cd..000000000
--- a/tests/run-make-fulldeps/c-link-to-rust-staticlib/foo.rs
+++ /dev/null
@@ -1,4 +0,0 @@
-#![crate_type = "staticlib"]
-
-#[no_mangle]
-pub extern "C" fn foo() {}