summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/c-link-to-rust-staticlib
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/c-link-to-rust-staticlib')
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-staticlib/Makefile12
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-staticlib/bar.c6
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-staticlib/foo.rs4
3 files changed, 0 insertions, 22 deletions
diff --git a/tests/run-make-fulldeps/c-link-to-rust-staticlib/Makefile b/tests/run-make-fulldeps/c-link-to-rust-staticlib/Makefile
deleted file mode 100644
index d38bcef30..000000000
--- a/tests/run-make-fulldeps/c-link-to-rust-staticlib/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-include ../tools.mk
-
-# ignore-freebsd
-# FIXME
-
-all:
- $(RUSTC) foo.rs
- $(CC) bar.c $(call STATICLIB,foo) $(call OUT_EXE,bar) \
- $(EXTRACFLAGS) $(EXTRACXXFLAGS)
- $(call RUN,bar)
- rm $(call STATICLIB,foo)
- $(call RUN,bar)
diff --git a/tests/run-make-fulldeps/c-link-to-rust-staticlib/bar.c b/tests/run-make-fulldeps/c-link-to-rust-staticlib/bar.c
deleted file mode 100644
index bb4036b06..000000000
--- a/tests/run-make-fulldeps/c-link-to-rust-staticlib/bar.c
+++ /dev/null
@@ -1,6 +0,0 @@
-void foo();
-
-int main() {
- foo();
- return 0;
-}
diff --git a/tests/run-make-fulldeps/c-link-to-rust-staticlib/foo.rs b/tests/run-make-fulldeps/c-link-to-rust-staticlib/foo.rs
deleted file mode 100644
index 2e59432cd..000000000
--- a/tests/run-make-fulldeps/c-link-to-rust-staticlib/foo.rs
+++ /dev/null
@@ -1,4 +0,0 @@
-#![crate_type = "staticlib"]
-
-#[no_mangle]
-pub extern "C" fn foo() {}