summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/windows-spawn
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/windows-spawn
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/windows-spawn')
-rw-r--r--tests/run-make-fulldeps/windows-spawn/Makefile8
-rw-r--r--tests/run-make-fulldeps/windows-spawn/hello.rs3
-rw-r--r--tests/run-make-fulldeps/windows-spawn/spawn.rs12
3 files changed, 0 insertions, 23 deletions
diff --git a/tests/run-make-fulldeps/windows-spawn/Makefile b/tests/run-make-fulldeps/windows-spawn/Makefile
deleted file mode 100644
index b6cdb169b..000000000
--- a/tests/run-make-fulldeps/windows-spawn/Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
-include ../tools.mk
-
-# only-windows
-
-all:
- $(RUSTC) -o "$(TMPDIR)/hopefullydoesntexist bar.exe" hello.rs
- $(RUSTC) spawn.rs
- $(TMPDIR)/spawn.exe
diff --git a/tests/run-make-fulldeps/windows-spawn/hello.rs b/tests/run-make-fulldeps/windows-spawn/hello.rs
deleted file mode 100644
index 47ad8c634..000000000
--- a/tests/run-make-fulldeps/windows-spawn/hello.rs
+++ /dev/null
@@ -1,3 +0,0 @@
-fn main() {
- println!("Hello World!");
-}
diff --git a/tests/run-make-fulldeps/windows-spawn/spawn.rs b/tests/run-make-fulldeps/windows-spawn/spawn.rs
deleted file mode 100644
index c34da3d5f..000000000
--- a/tests/run-make-fulldeps/windows-spawn/spawn.rs
+++ /dev/null
@@ -1,12 +0,0 @@
-use std::io::ErrorKind;
-use std::process::Command;
-
-fn main() {
- // Make sure it doesn't try to run "hopefullydoesntexist bar.exe".
- assert_eq!(Command::new("hopefullydoesntexist")
- .arg("bar")
- .spawn()
- .unwrap_err()
- .kind(),
- ErrorKind::NotFound);
-}