summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/windows-spawn
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/windows-spawn')
-rw-r--r--tests/run-make-fulldeps/windows-spawn/Makefile8
-rw-r--r--tests/run-make-fulldeps/windows-spawn/hello.rs3
-rw-r--r--tests/run-make-fulldeps/windows-spawn/spawn.rs12
3 files changed, 0 insertions, 23 deletions
diff --git a/tests/run-make-fulldeps/windows-spawn/Makefile b/tests/run-make-fulldeps/windows-spawn/Makefile
deleted file mode 100644
index b6cdb169b..000000000
--- a/tests/run-make-fulldeps/windows-spawn/Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
-include ../tools.mk
-
-# only-windows
-
-all:
- $(RUSTC) -o "$(TMPDIR)/hopefullydoesntexist bar.exe" hello.rs
- $(RUSTC) spawn.rs
- $(TMPDIR)/spawn.exe
diff --git a/tests/run-make-fulldeps/windows-spawn/hello.rs b/tests/run-make-fulldeps/windows-spawn/hello.rs
deleted file mode 100644
index 47ad8c634..000000000
--- a/tests/run-make-fulldeps/windows-spawn/hello.rs
+++ /dev/null
@@ -1,3 +0,0 @@
-fn main() {
- println!("Hello World!");
-}
diff --git a/tests/run-make-fulldeps/windows-spawn/spawn.rs b/tests/run-make-fulldeps/windows-spawn/spawn.rs
deleted file mode 100644
index c34da3d5f..000000000
--- a/tests/run-make-fulldeps/windows-spawn/spawn.rs
+++ /dev/null
@@ -1,12 +0,0 @@
-use std::io::ErrorKind;
-use std::process::Command;
-
-fn main() {
- // Make sure it doesn't try to run "hopefullydoesntexist bar.exe".
- assert_eq!(Command::new("hopefullydoesntexist")
- .arg("bar")
- .spawn()
- .unwrap_err()
- .kind(),
- ErrorKind::NotFound);
-}