summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-link-to-rust-staticlib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/c-link-to-rust-staticlib
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/c-link-to-rust-staticlib')
-rw-r--r--tests/run-make/c-link-to-rust-staticlib/Makefile13
-rw-r--r--tests/run-make/c-link-to-rust-staticlib/bar.c6
-rw-r--r--tests/run-make/c-link-to-rust-staticlib/foo.rs4
3 files changed, 23 insertions, 0 deletions
diff --git a/tests/run-make/c-link-to-rust-staticlib/Makefile b/tests/run-make/c-link-to-rust-staticlib/Makefile
new file mode 100644
index 000000000..e14775f5c
--- /dev/null
+++ b/tests/run-make/c-link-to-rust-staticlib/Makefile
@@ -0,0 +1,13 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-freebsd
+# FIXME
+
+all:
+ $(RUSTC) foo.rs
+ $(CC) bar.c $(call STATICLIB,foo) $(call OUT_EXE,bar) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,bar)
+ rm $(call STATICLIB,foo)
+ $(call RUN,bar)
diff --git a/tests/run-make/c-link-to-rust-staticlib/bar.c b/tests/run-make/c-link-to-rust-staticlib/bar.c
new file mode 100644
index 000000000..bb4036b06
--- /dev/null
+++ b/tests/run-make/c-link-to-rust-staticlib/bar.c
@@ -0,0 +1,6 @@
+void foo();
+
+int main() {
+ foo();
+ return 0;
+}
diff --git a/tests/run-make/c-link-to-rust-staticlib/foo.rs b/tests/run-make/c-link-to-rust-staticlib/foo.rs
new file mode 100644
index 000000000..2e59432cd
--- /dev/null
+++ b/tests/run-make/c-link-to-rust-staticlib/foo.rs
@@ -0,0 +1,4 @@
+#![crate_type = "staticlib"]
+
+#[no_mangle]
+pub extern "C" fn foo() {}