summaryrefslogtreecommitdiffstats
path: root/tests/run-make/compiler-lookup-paths-2
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/compiler-lookup-paths-2
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/compiler-lookup-paths-2')
-rw-r--r--tests/run-make/compiler-lookup-paths-2/Makefile8
-rw-r--r--tests/run-make/compiler-lookup-paths-2/a.rs1
-rw-r--r--tests/run-make/compiler-lookup-paths-2/b.rs2
-rw-r--r--tests/run-make/compiler-lookup-paths-2/c.rs3
4 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make/compiler-lookup-paths-2/Makefile b/tests/run-make/compiler-lookup-paths-2/Makefile
new file mode 100644
index 000000000..d4ff7d8da
--- /dev/null
+++ b/tests/run-make/compiler-lookup-paths-2/Makefile
@@ -0,0 +1,8 @@
+include ../tools.mk
+
+all:
+ mkdir -p $(TMPDIR)/a $(TMPDIR)/b
+ $(RUSTC) a.rs && mv $(TMPDIR)/liba.rlib $(TMPDIR)/a
+ $(RUSTC) b.rs -L $(TMPDIR)/a && mv $(TMPDIR)/libb.rlib $(TMPDIR)/b
+ $(RUSTC) c.rs -L crate=$(TMPDIR)/b -L dependency=$(TMPDIR)/a \
+ && exit 1 || exit 0
diff --git a/tests/run-make/compiler-lookup-paths-2/a.rs b/tests/run-make/compiler-lookup-paths-2/a.rs
new file mode 100644
index 000000000..83be6e807
--- /dev/null
+++ b/tests/run-make/compiler-lookup-paths-2/a.rs
@@ -0,0 +1 @@
+#![crate_type = "lib"]
diff --git a/tests/run-make/compiler-lookup-paths-2/b.rs b/tests/run-make/compiler-lookup-paths-2/b.rs
new file mode 100644
index 000000000..1be6cbc91
--- /dev/null
+++ b/tests/run-make/compiler-lookup-paths-2/b.rs
@@ -0,0 +1,2 @@
+#![crate_type = "lib"]
+extern crate a;
diff --git a/tests/run-make/compiler-lookup-paths-2/c.rs b/tests/run-make/compiler-lookup-paths-2/c.rs
new file mode 100644
index 000000000..e37bc2e1d
--- /dev/null
+++ b/tests/run-make/compiler-lookup-paths-2/c.rs
@@ -0,0 +1,3 @@
+#![crate_type = "lib"]
+extern crate b;
+extern crate a;