summaryrefslogtreecommitdiffstats
path: root/tests/run-make/dep-info-spaces/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/dep-info-spaces/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/dep-info-spaces/Makefile')
-rw-r--r--tests/run-make/dep-info-spaces/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/run-make/dep-info-spaces/Makefile b/tests/run-make/dep-info-spaces/Makefile
new file mode 100644
index 000000000..0cfe513e4
--- /dev/null
+++ b/tests/run-make/dep-info-spaces/Makefile
@@ -0,0 +1,19 @@
+include ../tools.mk
+
+# ignore-windows
+# ignore-freebsd
+# FIXME: (windows: see `../dep-info/Makefile`)
+
+all:
+ cp lib.rs $(TMPDIR)/
+ cp 'foo foo.rs' $(TMPDIR)/
+ cp bar.rs $(TMPDIR)/
+ $(RUSTC) --emit link,dep-info --crate-type=lib $(TMPDIR)/lib.rs
+ sleep 1
+ touch $(TMPDIR)/'foo foo.rs'
+ -rm -f $(TMPDIR)/done
+ $(MAKE) -drf Makefile.foo
+ rm $(TMPDIR)/done
+ pwd
+ $(MAKE) -drf Makefile.foo
+ rm $(TMPDIR)/done && exit 1 || exit 0