summaryrefslogtreecommitdiffstats
path: root/tests/run-make/dep-info-spaces/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/dep-info-spaces/Makefile')
-rw-r--r--tests/run-make/dep-info-spaces/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/run-make/dep-info-spaces/Makefile b/tests/run-make/dep-info-spaces/Makefile
new file mode 100644
index 000000000..0cfe513e4
--- /dev/null
+++ b/tests/run-make/dep-info-spaces/Makefile
@@ -0,0 +1,19 @@
+include ../tools.mk
+
+# ignore-windows
+# ignore-freebsd
+# FIXME: (windows: see `../dep-info/Makefile`)
+
+all:
+ cp lib.rs $(TMPDIR)/
+ cp 'foo foo.rs' $(TMPDIR)/
+ cp bar.rs $(TMPDIR)/
+ $(RUSTC) --emit link,dep-info --crate-type=lib $(TMPDIR)/lib.rs
+ sleep 1
+ touch $(TMPDIR)/'foo foo.rs'
+ -rm -f $(TMPDIR)/done
+ $(MAKE) -drf Makefile.foo
+ rm $(TMPDIR)/done
+ pwd
+ $(MAKE) -drf Makefile.foo
+ rm $(TMPDIR)/done && exit 1 || exit 0