summaryrefslogtreecommitdiffstats
path: root/tests/run-make/emit-stack-sizes
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/emit-stack-sizes
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/emit-stack-sizes')
-rw-r--r--tests/run-make/emit-stack-sizes/Makefile12
-rw-r--r--tests/run-make/emit-stack-sizes/foo.rs3
2 files changed, 15 insertions, 0 deletions
diff --git a/tests/run-make/emit-stack-sizes/Makefile b/tests/run-make/emit-stack-sizes/Makefile
new file mode 100644
index 000000000..f636ebd28
--- /dev/null
+++ b/tests/run-make/emit-stack-sizes/Makefile
@@ -0,0 +1,12 @@
+include ../tools.mk
+
+# ignore-windows
+# ignore-macos
+#
+# This feature only works when the output object format is ELF so we ignore
+# macOS and Windows
+
+# check that the .stack_sizes section is generated
+all:
+ $(RUSTC) -C opt-level=3 -Z emit-stack-sizes --emit=obj foo.rs
+ size -A $(TMPDIR)/foo.o | $(CGREP) .stack_sizes
diff --git a/tests/run-make/emit-stack-sizes/foo.rs b/tests/run-make/emit-stack-sizes/foo.rs
new file mode 100644
index 000000000..ee51ae328
--- /dev/null
+++ b/tests/run-make/emit-stack-sizes/foo.rs
@@ -0,0 +1,3 @@
+#![crate_type = "lib"]
+
+pub fn foo() {}