summaryrefslogtreecommitdiffstats
path: root/tests/run-make/extern-multiple-copies
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/extern-multiple-copies
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/extern-multiple-copies')
-rw-r--r--tests/run-make/extern-multiple-copies/Makefile9
-rw-r--r--tests/run-make/extern-multiple-copies/bar.rs6
-rw-r--r--tests/run-make/extern-multiple-copies/foo1.rs1
-rw-r--r--tests/run-make/extern-multiple-copies/foo2.rs1
4 files changed, 17 insertions, 0 deletions
diff --git a/tests/run-make/extern-multiple-copies/Makefile b/tests/run-make/extern-multiple-copies/Makefile
new file mode 100644
index 000000000..b0b84278e
--- /dev/null
+++ b/tests/run-make/extern-multiple-copies/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) foo1.rs
+ $(RUSTC) foo2.rs
+ mkdir $(TMPDIR)/foo
+ cp $(TMPDIR)/libfoo1.rlib $(TMPDIR)/foo/libfoo1.rlib
+ $(RUSTC) bar.rs --extern foo1=$(TMPDIR)/libfoo1.rlib -L $(TMPDIR)/foo
diff --git a/tests/run-make/extern-multiple-copies/bar.rs b/tests/run-make/extern-multiple-copies/bar.rs
new file mode 100644
index 000000000..c6b3595f6
--- /dev/null
+++ b/tests/run-make/extern-multiple-copies/bar.rs
@@ -0,0 +1,6 @@
+extern crate foo2; // foo2 first to exhibit the bug
+extern crate foo1;
+
+fn main() {
+ /* ... */
+}
diff --git a/tests/run-make/extern-multiple-copies/foo1.rs b/tests/run-make/extern-multiple-copies/foo1.rs
new file mode 100644
index 000000000..c1bfaa6ca
--- /dev/null
+++ b/tests/run-make/extern-multiple-copies/foo1.rs
@@ -0,0 +1 @@
+#![crate_type = "rlib"]
diff --git a/tests/run-make/extern-multiple-copies/foo2.rs b/tests/run-make/extern-multiple-copies/foo2.rs
new file mode 100644
index 000000000..c1bfaa6ca
--- /dev/null
+++ b/tests/run-make/extern-multiple-copies/foo2.rs
@@ -0,0 +1 @@
+#![crate_type = "rlib"]