summaryrefslogtreecommitdiffstats
path: root/tests/run-make/fpic
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/fpic
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/fpic')
-rw-r--r--tests/run-make/fpic/Makefile11
-rw-r--r--tests/run-make/fpic/hello.rs1
2 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/fpic/Makefile b/tests/run-make/fpic/Makefile
new file mode 100644
index 000000000..c38dd8d6e
--- /dev/null
+++ b/tests/run-make/fpic/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+# ignore-macos
+
+# Test for #39529.
+# `-z text` causes ld to error if there are any non-PIC sections
+
+all:
+ $(RUSTC) hello.rs -C link-args=-Wl,-z,text
diff --git a/tests/run-make/fpic/hello.rs b/tests/run-make/fpic/hello.rs
new file mode 100644
index 000000000..45590d86b
--- /dev/null
+++ b/tests/run-make/fpic/hello.rs
@@ -0,0 +1 @@
+fn main() { }