summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-36710
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make/issue-36710
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/issue-36710')
-rw-r--r--tests/run-make/issue-36710/Makefile17
-rw-r--r--tests/run-make/issue-36710/foo.cpp15
-rw-r--r--tests/run-make/issue-36710/foo.rs10
3 files changed, 42 insertions, 0 deletions
diff --git a/tests/run-make/issue-36710/Makefile b/tests/run-make/issue-36710/Makefile
new file mode 100644
index 000000000..d6145c071
--- /dev/null
+++ b/tests/run-make/issue-36710/Makefile
@@ -0,0 +1,17 @@
+# ignore-none no-std is not supported
+# ignore-wasm32 FIXME: don't attempt to compile C++ to WASM
+# ignore-wasm64 FIXME: don't attempt to compile C++ to WASM
+# ignore-nvptx64-nvidia-cuda FIXME: can't find crate for `std`
+# ignore-musl FIXME: this makefile needs teaching how to use a musl toolchain
+# (see dist-i586-gnu-i586-i686-musl Dockerfile)
+
+include ../../run-make-fulldeps/tools.mk
+
+all: foo
+ $(call RUN,foo)
+
+foo: foo.rs $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) $< -lfoo $(EXTRARSCXXFLAGS) --target $(TARGET)
+
+$(TMPDIR)/libfoo.o: foo.cpp
+ $(call COMPILE_OBJ_CXX,$@,$<)
diff --git a/tests/run-make/issue-36710/foo.cpp b/tests/run-make/issue-36710/foo.cpp
new file mode 100644
index 000000000..8f878c2c2
--- /dev/null
+++ b/tests/run-make/issue-36710/foo.cpp
@@ -0,0 +1,15 @@
+#include <stdint.h>
+
+struct A {
+ A() { v = 1234; }
+ ~A() { v = 1; }
+ uint32_t v;
+};
+
+A a;
+
+extern "C" {
+ uint32_t get() {
+ return a.v;
+ }
+}
diff --git a/tests/run-make/issue-36710/foo.rs b/tests/run-make/issue-36710/foo.rs
new file mode 100644
index 000000000..f30a35e27
--- /dev/null
+++ b/tests/run-make/issue-36710/foo.rs
@@ -0,0 +1,10 @@
+// Tests that linking to C++ code with global destructors works.
+
+extern "C" {
+ fn get() -> u32;
+}
+
+fn main() {
+ let i = unsafe { get() };
+ assert_eq!(i, 1234);
+}